Bug 641178 - Groups: Problem Groups view appears to be congruent with "(All) Groups" view.
Summary: Groups: Problem Groups view appears to be congruent with "(All) Groups" view.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RHQ Project
Classification: Other
Component: Core UI
Version: 4.0.0
Hardware: All
OS: Linux
low
medium vote
Target Milestone: ---
: ---
Assignee: RHQ Project Maintainer
QA Contact: Corey Welton
URL:
Whiteboard:
Depends On:
Blocks: rhq4 gwt-groups
TreeView+ depends on / blocked
 
Reported: 2010-10-07 23:20 UTC by Corey Welton
Modified: 2011-05-24 01:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-24 01:12:14 UTC


Attachments (Terms of Use)

Description Corey Welton 2010-10-07 23:20:27 UTC
Description of problem:
There seems to be no difference in the default "Saved Searches > Problem Groups" view and the top-level Groups view.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Create a variety of different groups, mixed, dyna, compat [platform, server, service]. Guarantee at least one of this is absolutely fine/clean, e.g., a non-recursive group of Hosts files that are up.  (What you're trying to do here is assure there is nothing wrong with any resource in this group)
2.  Navigate to Inventory > Groups view.  
3.  Navigate to Inventory > Saved Searches > Problem Groups
4.  Compare these two

  
Actual results:
Same exact values.  The "green" group you created above shows up in problem resources.

Expected results:
I am not exactly sure what "Problem Groups" is, but if we're providing it to the customer ahead of time, it should be somewhat correct.  

Additional info:

Comment 1 Jay Shaughnessy 2011-02-17 20:00:09 UTC
seems to work now.

Comment 2 Sunil Kondkar 2011-04-20 11:47:52 UTC
Verified on build#1144 (Version: 4.0.0-SNAPSHOT Build Number: 50f58a4)

Created different groups having all green resources. The 'Problem groups' does not show any resources.

Marking as verified.

Comment 3 Corey Welton 2011-05-24 01:12:14 UTC
Bookkeeping - closing bug - fixed in recent release.

Comment 4 Corey Welton 2011-05-24 01:12:14 UTC
Bookkeeping - closing bug - fixed in recent release.


Note You need to log in before you can comment on or make changes to this bug.