Bug 641184 - Groups: Cannot modify Description of a Group if tags are populated
Groups: Cannot modify Description of a Group if tags are populated
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
:
Depends On:
Blocks: rhq4 gwt-groups
  Show dependency treegraph
 
Reported: 2010-10-07 20:14 EDT by Corey Welton
Modified: 2011-05-23 21:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-23 21:09:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2010-10-07 20:14:47 EDT
Description of problem:
As long as a group is "tagged" with some value, the description fails to be modified.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a group, either mixed or compatible
2. Navigate to the view for this group
3. Edit the description field multiple times -- change the values a variety of different ways, "foo", "bar", "baz".  Note successful modification.
4. Click the green tag "+" above and add some string as a tag
5. Repeat step 3 - note results
6. Remove tag(s)
7. Repeat step 3 - note results

Actual results:
As long as a group is tagged, the Description field cannot be modified. Removing those tags allows it to be modified.

Expected results:
Some normal user workflow

Additional info:
* If tagging doesn't make it into the final product, we can close this out.  Until then, tagging can cause a failure to edit these as appropriate.
* I have not yet tried this for individual resources.  May occur there too
Comment 1 Jay Shaughnessy 2011-02-14 10:02:30 EST
Could not reproduce.
Comment 2 Corey Welton 2011-02-14 14:19:45 EST
Seems to work now.  Verified.
Comment 3 Corey Welton 2011-05-23 21:09:20 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.