Bug 641205 - Groups: Inventory > Membership: Removing "Bundle Handler - Ant" from a group throws error
Groups: Inventory > Membership: Removing "Bundle Handler - Ant" from a group ...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
:
Depends On:
Blocks: rhq4 gwt-groups
  Show dependency treegraph
 
Reported: 2010-10-07 22:17 EDT by Corey Welton
Modified: 2011-05-23 21:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-23 21:12:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2010-10-07 22:17:22 EDT
Description of problem:
For some reason, this particular resource throws an error when removing it from a group.  It appears it can be added just fine, but trying to drag it back over to the resource list gives an error

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Create a mixed group of various sundry resources, "MixMix". 
2.  Inventory > Groups > Mixed Group > "MixMix"
3.  Click on Inventory > Membership subtab of the group view
4.  Begin dragging various other resources over to the right-hand pane.   Assure "Bundle Handler - Ant" is one of them.
5.  Attempt to drag resources back.  Again, assure "Bundle Handler - Ant" is one of them.  View results

Actual results:
The resource in question seem to be readily addable, but attempting to remove it nets an error message:

Failure in Datasource [ADD]  Hovering atop the error icon nets a "java.lang.UnsupportedOperationException" error

Expected results:


Additional info:
Comment 1 Jay Shaughnessy 2011-02-14 09:59:31 EST
Could not reproduce.
Comment 2 Corey Welton 2011-02-14 14:17:39 EST
No longer seems to occur.  Considering it verified.
Comment 3 Corey Welton 2011-05-23 21:12:10 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 4 Corey Welton 2011-05-23 21:12:10 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.