Bug 641223 - ibus Alt+Shift is not used as hot key.
ibus Alt+Shift is not used as hot key.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-08 00:06 EDT by fujiwara
Modified: 2010-10-22 00:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-08 01:04:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description fujiwara 2010-10-08 00:06:43 EDT
IBus assigns Alt+Shift_L as hot key by default but the shortcut key cannot be used.
Comment 1 fujiwara 2010-10-08 01:04:46 EDT
Sorry, it seems this problem exists with gnome-terminal only.
I can use Alt+Shift_L with gedit, evolution, xterm.
Closing this as not a bug.

On the other hand, Shift+Alt_L does not work but probably it's not needed since we could use Alt+Shift_L.

If users use the "Please press a key" dialog, it detects Alt+Shift+Shift_L but GTK2 event filter removes Shift modifier if the keyval is Shift_(L|R) so user need to uncheck the Shift modifier box by manual and change Alt+Shift+Shift_L to Alt+Shift_L .
Comment 2 fujiwara 2010-10-22 00:48:52 EDT
Hmm.., thinking this again, it seems this problem can be fixed with IBUS_SNOOPER=1 with gnome-terminal.
How important is this bug for f14?

Note You need to log in before you can comment on or make changes to this bug.