Bug 641337 - gnome-terminal-2.33.0-2.fc15.x86_64 starts "full screen" with no active shell....
gnome-terminal-2.33.0-2.fc15.x86_64 starts "full screen" with no active shell...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-08 09:27 EDT by Tom London
Modified: 2010-10-09 23:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-09 23:27:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 631797 None None None Never

  None (edit)
Description Tom London 2010-10-08 09:27:34 EDT
Description of problem:
Updating to gnome-terminal-2.33.0-2.fc15.x86_64, I can't get a working gnome-terminal....

Starting one produces a "full screen" window with no active shell, not responsive to keystrokes, mouse clicks, etc.

If I start an 'xterm' window and start gnome-terminal from that, I see:
Gtk-Message: Failed to load module "pk-gtk-module": libpk-gtk-module.so: cannot open shared object file: No such file or directory

Downgrading to gnome-terminal-2.33.0-1.fc15.x86_64 appears to "make it work for me".

Version-Release number of selected component (if applicable):
gnome-terminal-2.33.0-2.fc15.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Yanko Kaneti 2010-10-08 09:39:45 EDT
At least here the shell is started but the vte widget itself if extended much beyond the dimensions of the g-t window above its upper end. Hold enter and the prompt will show itself when the lines fill. Something similar is happening to the right.
Comment 2 Owen Taylor 2010-10-08 18:08:01 EDT
After digging into this for most of today, it's significantly hard to make the gtk3 build work right. Changes in gtk3 behavior:

 https://bugzilla.gnome.org/show_bug.cgi?id=631699

Have broken both the workarounds for handling gridding correctly:

 https://bugzilla.gnome.org/show_bug.cgi?id=68668

And the basic way that resizing in gnome-terminal works correctly. I'll work more on getting good fixes upstream, but for now building a new gnome-terminal that reverts back to gtk2:

 http://koji.fedoraproject.org/koji/taskinfo?taskID=2523751

So we have a working terminal in rawhide.
Comment 3 Tom London 2010-10-09 10:41:16 EDT
gnome-terminal-2.33.0-3.fc15.x86_64 works for me.....

Leave this open until the sizing is 'fixed'?
Comment 4 Owen Taylor 2010-10-09 23:20:27 EDT
See referenced gnome-terminal bug and the GTK+ bugs it depends upon for fixes. 

(Ended up fixing a GTK+ bug that I introduced to GTK+ in 1998 and filed in GNOME bugzilla in 2002, so I guess that's some good forcing of dealing with bugs that have been around too long. Or *I've* just been around GNOME too long. One or the other.)

Note You need to log in before you can comment on or make changes to this bug.