Bug 641350 - implicit destructor of CppUnit::Message causes segfault when test is built with debug. STL
implicit destructor of CppUnit::Message causes segfault when test is built wi...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cppunit (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-08 09:43 EDT by David Tardon
Modified: 2011-07-12 01:18 EDT (History)
2 users (show)

See Also:
Fixed In Version: cppunit-1.12.1-5.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-12 00:47:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
reproducer (142 bytes, text/plain)
2010-10-08 09:43 EDT, David Tardon
no flags Details
valgrind log (6.67 KB, text/plain)
2010-10-08 09:44 EDT, David Tardon
no flags Details
fix it (928 bytes, patch)
2010-10-08 09:44 EDT, David Tardon
no flags Details | Diff

  None (edit)
Description David Tardon 2010-10-08 09:43:18 EDT
Created attachment 452337 [details]
reproducer

Description of problem:
CppUnit::Message contains a std::deque. Because the class doesn't
declare destructor, the compiler synthetises one in every compilation
unit where the class is used. But now, if the compilation unit is
compiled with debugging STL support (i.e. with -D_GLIBCXX_DEBUG), the
synthetised ~Message destructs the deque member by calling
std::__debug::deque::~deque instead of std::deque::~deque, with expected
consequences.

Version-Release number of selected component (if applicable):
cppunit-1.12.1-3.fc15

How reproducible:
always with the attached reproducer

Steps to Reproduce:
1. g++ -o cppunit -Wall -g -O0 $(pkg-config --cflags --libs cppunit) -D_GLIBCXX_DEBUG cppunit.cc
2. ./cppunit
Comment 1 David Tardon 2010-10-08 09:44:02 EDT
Created attachment 452338 [details]
valgrind log
Comment 2 David Tardon 2010-10-08 09:44:31 EDT
Created attachment 452340 [details]
fix it
Comment 3 David Tardon 2010-10-31 04:32:43 EDT
ping?
Comment 4 David Tardon 2010-12-18 11:49:53 EST
ping
Comment 5 David Tardon 2011-01-24 00:27:41 EST
hey, are you there?
Comment 6 Fedora Update System 2011-06-30 08:38:24 EDT
cppunit-1.12.1-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/cppunit-1.12.1-5.fc15
Comment 7 Fedora Update System 2011-06-30 08:45:23 EDT
cppunit-1.12.1-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/cppunit-1.12.1-5.fc14
Comment 8 Fedora Update System 2011-06-30 14:56:51 EDT
Package cppunit-1.12.1-5.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cppunit-1.12.1-5.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/cppunit-1.12.1-5.fc14
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2011-07-12 00:47:44 EDT
cppunit-1.12.1-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2011-07-12 01:18:19 EDT
cppunit-1.12.1-5.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.