Bug 641361 (CVE-2010-3430, CVE-2010-3431) - CVE-2010-3430 CVE-2010-3431 pam: pam_mail and pam_env incorrect privilege dropping
Summary: CVE-2010-3430 CVE-2010-3431 pam: pam_mail and pam_env incorrect privilege dro...
Status: CLOSED NOTABUG
Alias: CVE-2010-3430, CVE-2010-3431
Product: Security Response
Classification: Other
Component: vulnerability   
(Show other bugs)
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,source=oss-security,r...
Keywords: Security
Depends On:
Blocks: CVE-2010-3435
TreeView+ depends on / blocked
 
Reported: 2010-10-08 14:16 UTC by Tomas Hoger
Modified: 2015-07-31 06:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-22 15:45:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tomas Hoger 2010-10-08 14:16:04 UTC
The pam_mail and pam_env modules in Linux-PAM before 1.1.2 did not drop privileges before accessing users' files (CVE-2010-3435, see bug #641335).  Privilege dropping was added in 1.1.2, but with couple of issues pointed out by Solar Designer:

http://thread.gmane.org/gmane.comp.security.oss.general/3311/focus=3534

The code fails to switch fsgid/egid and groups (CVE-2010-3430) and does not check setfsuid() return value (CVE-2010-3431).  Fix using newly-introduced pam_modutil_drop_priv / pam_modutil_regain_priv was committed in upstream CVS and should be included in 1.1.3:
http://git.altlinux.org/people/ldv/packages/?p=pam.git;a=commitdiff;h=843807a3a90f52e7538be756616510730a24739a

Comment 1 Tomas Hoger 2010-10-08 14:19:01 UTC
Linux-PAM 1.1.2 is currently only available in Fedora Rawhide.  Older PAM versions do to contain affected privilege dropping code and hence can not be affected by these issues.  The are affected by the original issue - CVE-2010-3435.

Statement:

Not vulnerable. This issue did not affect the versions of pam as shipped with Red Hat Enterprise Linux 3, 4, 5, or 6.


Note You need to log in before you can comment on or make changes to this bug.