This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 641476 - devicemapper UUID field cannot be assigned after map creation
devicemapper UUID field cannot be assigned after map creation
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
14
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: 584328
  Show dependency treegraph
 
Reported: 2010-10-08 15:57 EDT by James Laska
Modified: 2013-09-02 02:51 EDT (History)
16 users (show)

See Also:
Fixed In Version: 2.6.35.6-44.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 584328
Environment:
Last Closed: 2010-10-19 01:02:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Laska 2010-10-08 15:57:22 EDT
In order to properly resolve an issue originally discovered in bug#584328, a fix to kernel and lvm2 is also required.  Please see below for details from dlehman@redhat.com.

+++ This bug was initially created as a clone of Bug #584328 +++

The following was filed automatically by anaconda:
anaconda 13.37.2 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1066, in populate
    devstring = device.name
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1836, in getScreen
    self.populate(initial = 1)
  File "/usr/lib/anaconda/gui.py", line 1393, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
  File "/usr/lib/anaconda/gui.py", line 1314, in nextClicked
    self.setScreen ()
AttributeError: 'NoneType' object has no attribute 'name'

<snip>

--- Additional comment from dlehman@redhat.com on 2010-10-08 13:36:31 EDT ---

pjones is working on a patch to the kernel (device-mapper) to allow setting of uuid for already-existing maps, as long as they have no uuid at that time. 

Patches will also be required for libdevmapper to provide a function along the lines of the existing function dm_task_set_newname, but for uuid instead of name. I have drafted a patch to pyblock that will make use of all of the above to ensure correct uuids are set for dmraid and mpath devices created by pyblock.

--- Additional comment from awilliam@redhat.com on 2010-10-08 14:16:10 EDT ---

At the 2010-10-08 blocker meeting we agreed to reassign this bug to pyblock and create new bugs against kernel and libdevmapper which block this bug. Jlaska will be doing this.
Comment 1 James Laska 2010-10-11 16:16:30 EDT
Please note, this bug is on the dependency chain as blocking the release of F14 blocker.  Please help resolve this issue as quickly as possible.
Comment 2 Peter Jones 2010-10-11 16:29:58 EDT
A patch has been posted to dm-devel as of Friday, 8-Oct-2010, and has been updated a couple of times since then.
Comment 3 Milan Broz 2010-10-11 16:58:44 EDT
Seems Alasdair said on dm-devel that he will accept the kernel patch the "old way", assigning to him.
Comment 4 Alasdair Kergon 2010-10-12 07:55:04 EDT
This seems to be the proposed patch for me to review:

https://patchwork.kernel.org/patch/242631/
Comment 5 Paul W. Frields 2010-10-12 10:34:51 EDT
FYI, as seen in bug 641474: "The F14 devel schedule
(http://poelstra.fedorapeople.org/schedules/f-14/f-14-devel-tasks.html) says
that the final change deadline is 18 October."  Thanks for your prompt attention!
Comment 6 Dave Jones 2010-10-13 13:04:53 EDT
Should be fixed in 2.6.35.6-42
Comment 7 Fedora Update System 2010-10-13 19:35:00 EDT
kernel-2.6.35.6-43.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kernel-2.6.35.6-43.fc14
Comment 8 Alasdair Kergon 2010-10-14 12:33:12 EDT
Patch reviewed and accepted into the upstream device-mapper queue for 2.6.37.  I have done some refactoring, but there is no difference of any significance to its functionality.
Comment 9 Alasdair Kergon 2010-10-15 09:54:58 EDT
Peter Rajnoha tested this thoroughly this morning and was able to make the dm remove ioctl hang.  A one-line fix to the patch is required.
Comment 10 Adam Williamson 2010-10-15 12:35:30 EDT
Discussed at the 2010-10-15 blocker review meeting. pjones is working on this whole set of bugs and expects it to be cleaned up today.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Fedora Update System 2010-10-18 01:40:22 EDT
kernel-2.6.35.6-43.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 James Laska 2010-10-18 12:41:59 EDT
(In reply to comment #11)
> kernel-2.6.35.6-43.fc14 has been pushed to the Fedora 14 stable repository.  If
> problems still persist, please make note of it in this bug report.

Moving into ON_QA as an updated kernel is available with the fix.

https://admin.fedoraproject.org/updates/kernel-2.6.35.6-43.fc14
Comment 13 Jesse Keating 2010-10-19 01:02:10 EDT
That kernel is in stable now.

Note You need to log in before you can comment on or make changes to this bug.