Bug 64151 - mgetty dies, does not cancel lock file & respawn
mgetty dies, does not cancel lock file & respawn
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mgetty (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-26 13:16 EDT by Steve Wells
Modified: 2007-05-16 22:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-03 18:58:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Wells 2002-04-26 13:16:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Using hyperterm to connect to Linux box with 56K internal modem & mgetty 
configured for ttyS4, abruptly disconnect the connection in the middle of a 
task (ala cat a file or ls a directory) without logging out completely.  The 
mgetty dies (no longer shows up on ps) but the ttyS4 lock file remains.  The 
mgetty will never respawn, however, and subsequent attempts to dial into the 
box will never be answered.

Version-Release number of selected component (if applicable):


How reproducible:
Always / Sometimes

Steps to Reproduce:
1.spawn mgetty for internal modem
2.dial into box using hyperterm or other equivalent
3.run "cat" on a file or "ls" in a directory
4.abruptly disconnect the connection without logging out
5.redial box, phone line rings, no answer by mgetty
6.run ps on box, see that mgetty has not been respawned
7.check /var/lock dir & see that ttyS4 lock file is still present

Actual Results:  modem placed into state where mgetty is never respawned and 
will not answer line (even if lock file is removed).

Expected Results:  modem cd loss would disable mgetty, cause lock file to be 
removed, and mgetty respawned & answer subsequent calls to box when ringing.

Additional info:

One factor may involve phone line quality or modem / RS-232 signal detection re 
CD + DTR?  This problem has not been duplicated using a Black Box phone 
simulator but very easily using other combinations of modems & phone lines.
Comment 1 Steve Wells 2002-05-03 14:55:23 EDT
mgetty.log entries state that the release is an "Experimental Version"
Comment 2 Alan Cox 2002-12-18 11:52:04 EST
Unable to duplicate but leaving open since conditions often play a critical part
in such things
Comment 3 Jason Vas Dias 2005-06-03 18:58:17 EDT
Closing out old bugs here.
I'm unable to duplicate this bug. If anyone can duplicate it with
current mgetty versions, please let me know how.
Comment 4 Thomas Sprinkmeier 2007-05-16 22:31:27 EDT
I experienced this bug too when using a cheap dual-RS232 card.
I've changed to a USB-RS232 adapter and now _this_ problem has gone away.
Now I'm stuck with Bug #167830.

Using vanilla FC5 system.

Note You need to log in before you can comment on or make changes to this bug.