Bug 64155 - fdisk -> delete partition -> Segmentation fault
fdisk -> delete partition -> Segmentation fault
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
7.2
i686 Linux
high Severity high
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-26 14:13 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-28 13:27:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-04-26 14:13:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; T312461)

Description of problem:
Impossible to delete some partitions.

[root@echelon hdc1]# fdisk /dev/hdb
Advertencia: demasiadas particiones (16, el valor mC!ximo es 8).

Comando (m para obtener ayuda): p

Disco /dev/hdb: 64 cabezales, 63 sectores, 525 cilindros
Unidades = cilindros de 4032 * 512 bytes


16 particiones:
#       start       end      size     fstype   [fsize bsize   cpg]
  a:        1       203       203     4.2BSD     1024  8192    16
  b:      204       268        65       swap
  c:        1      2100      2100     unused        0     0
  d:      269       634       366     4.2BSD     1024  8192    16
  e:      635       675        41     4.2BSD     1024  8192    16

Comando (m para obtener ayuda): d
Numero de particion (1-4): 4
Segmentation fault
[root@echelon root]#


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.fdisk /dev/hdb over a disk with 4.2bsd partitions
2.
3.
	

Actual Results:  core dump

Additional info:

Package utils-linux seems to be correct.
# rpm -V util-linux-2.11f-17
.M....G.   /usr/bin/chfn
Comment 1 Need Real Name 2002-04-28 19:10:00 EDT
Reset partition info with Partition Magic 4.0 and create a ext2 partition for 
all disk  with PQ Magic 4 too. 
Then I reset to linux again and here is the result:

[root@echelon root]# fdisk /dev/hdb
Advertencia: demasiadas particiones (16, el valor maximo es 8).

Comando (m para obtener ayuda): p

Disco /dev/hdb: 64 cabezales, 63 sectores, 525 cilindros
Unidades = cilindros de 4032 * 512 bytes


16 particiones:
#       start       end      size     fstype   [fsize bsize   cpg]
  a:        1       203       203     4.2BSD     1024  8192    16
  b:      204       268        65       swap
  c:        1      2100      2100     unused        0     0
  d:      269       634       366     4.2BSD     1024  8192    16
  e:      635       675        41     4.2BSD     1024  8192    16


I am viewing the same info!!! Incredible

But here is something more strange, as I told before I create a unique ext 2 
partition for all disk (1Gb)..

[root@echelon root]# mount /dev/hdb1 /mnt/red1/
[root@echelon root]#

Ups! no error!!

[root@echelon root]# mount
[...]
/dev/hdb1 on /mnt/red1 type ext2 (rw)

WHAAAAT?
I can't understand anything. :/
Comment 2 Elliot Lee 2002-06-20 11:38:13 EDT
Need a way to reliably reproduce

Note You need to log in before you can comment on or make changes to this bug.