Bug 64156 - anaconda exits when specifying disk to partition
anaconda exits when specifying disk to partition
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-26 14:43 EDT by Clark Shishido
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-26 15:43:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bad ks.cfg (855 bytes, text/plain)
2002-04-26 14:44 EDT, Clark Shishido
no flags Details
ks.cfg generated after a cd-rom install (1.19 KB, text/plain)
2002-04-26 14:45 EDT, Clark Shishido
no flags Details
anaconda's dump (44.08 KB, text/plain)
2002-04-26 14:47 EDT, Clark Shishido
no flags Details
ks.cfg from the floppy only passwords removed (832 bytes, text/plain)
2002-04-26 15:43 EDT, Clark Shishido
no flags Details

  None (edit)
Description Clark Shishido 2002-04-26 14:43:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; FreeBSD i386; U;) Gecko/0

Description of problem:
When specifying a disk to partition, /dev/sda, anaconda exits.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. use bootnet.img (20020117 with or without update.img), use attached ks-bad.cfg
2. # linux apic ks=floppy
	

Actual Results:  ananconda dumps to screen when trying to partition the disk.

clearpart --all --initlabel
part /boot --fstype ext3 --size 64 --asprimary --ondisk /dev/sda 
part / --fstype ext3 --size 512 --asprimary --ondisk /dev/sda 
part  swap --size 2048 --asprimary --ondisk /dev/sda 
part /usr --fstype ext3 --size 2048 --ondisk /dev/sda 
part /var --fstype ext3 --size 8192 --ondisk /dev/sda 
part  swap --size 2048 --ondisk /dev/sda  --ondisk /dev/sda
part /home --fstype ext3 --size 1 --grow --ondisk /dev/sda 


Expected Results:  anaconda should partition disk as laid out in ks.cfg

Additional info:

Also attached is the anaconda-ks.cfg after a cdrom install when I used diskdruid
just to make sure the disk was big enough and my partitioning is sane.

I'm booting with the apic flag because it's an Intel L440GX+ motherboard.
Comment 1 Clark Shishido 2002-04-26 14:44:30 EDT
Created attachment 55504 [details]
bad ks.cfg
Comment 2 Clark Shishido 2002-04-26 14:45:56 EDT
Created attachment 55505 [details]
ks.cfg generated after a cd-rom install
Comment 3 Clark Shishido 2002-04-26 14:47:42 EDT
Created attachment 55506 [details]
anaconda's dump
Comment 4 Clark Shishido 2002-04-26 14:50:18 EDT
Workaround: let anaconda autopartition disk. In my case it uses the 2nd disk it
sees for swap and /home, so I have to uninstall my 2nd SCSI disk and remove
--ondisk /dev/sda from ks.cfg.
Comment 5 Michael Fulbright 2002-04-26 15:21:30 EDT
You have --ondisk listed twice for the swap partition, not sure if that makes a
difference.

Could you try this errata:

http://www.redhat.com/support/errata/RHBA-2002-016.html

It resolved several issues related to ks partitioning.
Comment 6 Clark Shishido 2002-04-26 15:40:05 EDT
that second --ondisk is an editting error on my part.
I just double checked with the attached ks.cfg (w/o passwords)
with both

# linux apic ks=floppy and
# linux updates apic ks=floppy

I've been doing the majority of this trouble shooting with
the 20020117 bootnet and update images.
I'm also aware of the following when I first started 
trying to assign partitions.
http://www.redhat.com/docs/errata/RHL-7.2-Manual/
Comment 7 Clark Shishido 2002-04-26 15:43:12 EDT
Created attachment 55525 [details]
ks.cfg from the floppy only passwords removed
Comment 8 Jeremy Katz 2002-04-26 17:04:27 EDT
It should be --ondisk sda, not --ondisk /dev/sda
Comment 9 Clark Shishido 2002-04-26 17:41:23 EDT
sorry for wasting everybody's bandwidth, I'm still think 
devices start with a /dev. I thought ksconfig would give
me a better start than /root/anaconda-ks.cfg; now I see
the error of my ways.    --clark

Note You need to log in before you can comment on or make changes to this bug.