Bug 64161 - Inconsistent sourcing in of /etc/profile.d/*.sh files
Summary: Inconsistent sourcing in of /etc/profile.d/*.sh files
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: fileutils   
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: wdovlrrw
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-26 21:52 UTC by john.l.villalovos
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-26 21:52:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description john.l.villalovos 2002-04-26 21:52:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1)
Gecko/20020417

Description of problem:
The /etc/profile script sources in files from /etc/profile.d/*.sh if they are
"Readable".

The /etc/bashrc script sources in files from /etc/profile.d/*.sh if they are
executable.

This leads to cases where things work in an "interactive login shell" but not in
a "interactive NON-login shell".  That is because if a *.sh file in
/etc/profile.d/ is readable but not executable it will be run in the login shell
but not in the non-login shell.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Additional info:

Comment 1 Florian La Roche 2002-07-20 06:52:31 UTC
Both are now sourcing if readable.

Thanks a lot,

Florian La Roche



Note You need to log in before you can comment on or make changes to this bug.