Bug 641789 - Kernel on F14 needs acpi_sleep=nonvs to resume from suspend correctly
Summary: Kernel on F14 needs acpi_sleep=nonvs to resume from suspend correctly
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 14
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-11 05:58 UTC by Maxim Burgerhout
Modified: 2011-11-29 00:21 UTC (History)
7 users (show)

Fixed In Version: kernel-2.6.35.14-106.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-30 00:30:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci output (2.25 KB, text/plain)
2010-10-11 05:58 UTC, Maxim Burgerhout
no flags Details
/var/log/messages at suspend; show cold boot directly after (3.34 KB, text/plain)
2010-10-11 06:05 UTC, Maxim Burgerhout
no flags Details
Output of dmidecode (6.02 KB, application/octet-stream)
2011-10-17 18:05 UTC, Maxim Burgerhout
no flags Details
dmidecode from Sony VPCEB17FX (6.14 KB, text/plain)
2011-10-27 21:53 UTC, Eric Smith
no flags Details

Description Maxim Burgerhout 2010-10-11 05:58:59 UTC
Created attachment 452643 [details]
lspci output

Description of problem:
After closing the lid of my laptop, suspend seems to work fine. System powers down, orange 'suspended' LED light is on.

When pressing the power button to resume the laptop, the system does not resume, but does a cold boots.

I hope it is correct to file this bug against the kernel.

Version-Release number of selected component (if applicable):
kernel-2.6.35.6-39.fc14.x86_64

How reproducible:
Happens always.

Steps to Reproduce:
1. shut lid to suspend
2. press 'power' to resume
  
Actual results:
cold boot

Expected results:
resume previous state

Comment 1 Maxim Burgerhout 2010-10-11 06:05:05 UTC
Created attachment 452647 [details]
/var/log/messages at suspend; show cold boot directly after

Comment 2 Maxim Burgerhout 2010-10-18 09:25:29 UTC
After a little poking around, it turns out that this is a generic bug in 2.6.35 as it is also discussed on (at least) the Ubuntu[1] and Arch Linux [2] forums as well.

The original upstream bugzilla entry for it is here [3]. Comments #82 through #84 on that bugreport mention a patch for 2.6.36 to blacklist systems that need acpi_sleep=nonvs in acpisleep_dmi_table[].

As I am not a kernel developer, I have no idea whatsoever what the amount of work to do this would be but: would it be possible to incorporate this patch into 2.6.35 for F14? Not having a working suspend option kinda sucks...

[1] http://ubuntuforums.org/showpost.php?p=9934814&postcount=42
[2] https://bbs.archlinux.org/viewtopic.php?id=80702
[3] https://bugzilla.kernel.org/show_bug.cgi?id=16396

Comment 3 Dave Jones 2011-10-11 15:25:20 UTC
what laptop is this ? Can you attach the output of dmidecode please ?

Comment 4 Maxim Burgerhout 2011-10-17 18:05:05 UTC
Created attachment 528615 [details]
Output of dmidecode

dmidecode output attached

Comment 5 Dave Jones 2011-10-19 17:16:46 UTC
thanks. I just added a patch for the next build.
I've also posted it upstream, so it should get into future releases.

Comment 6 Maxim Burgerhout 2011-10-21 09:30:44 UTC
Thanks! What Fedora release did you patch for? I am still having this problem in the F16 betas, so I'd love to see the patch in there, too.

Comment 7 Dave Jones 2011-10-21 16:27:32 UTC
I added the patch to all branches. Should start showing up everywhere soon.

Comment 8 Fedora Update System 2011-10-21 20:46:15 UTC
kernel-2.6.35.14-100.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kernel-2.6.35.14-100.fc14

Comment 9 Fedora Update System 2011-10-22 08:26:30 UTC
Package kernel-2.6.35.14-100.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-2.6.35.14-100.fc14'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-14747
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2011-10-24 15:12:47 UTC
kernel-2.6.40.7-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40.7-3.fc15

Comment 11 Fedora Update System 2011-10-27 14:12:59 UTC
kernel-2.6.40.8-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40.8-2.fc15

Comment 12 Eric Smith 2011-10-27 21:53:24 UTC
Created attachment 530575 [details]
dmidecode from Sony VPCEB17FX

Same problem occurs with Sony VPCEB17FX.

Comment 13 Fedora Update System 2011-10-30 00:30:53 UTC
kernel-2.6.35.14-100.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Eric Smith 2011-10-30 03:13:22 UTC
So since this still happens with the Sony VPCEB17FX, should I reopen this bug, or start a new one?

Comment 15 Dave Jones 2011-11-01 16:51:21 UTC
just sent a patch to fix that one upstream. I'll add it to all the fedora trees too. Don't worry about opening another bug. thanks for the debug info.

Comment 16 Fedora Update System 2011-11-01 19:58:17 UTC
kernel-2.6.40.8-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40.8-4.fc15

Comment 17 Fedora Update System 2011-11-12 00:07:14 UTC
kernel-2.6.41.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.41.1-1.fc15

Comment 18 Fedora Update System 2011-11-17 23:27:58 UTC
kernel-2.6.41.1-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2011-11-22 13:48:31 UTC
kernel-2.6.35.14-105.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kernel-2.6.35.14-105.fc14

Comment 20 Fedora Update System 2011-11-23 15:38:20 UTC
kernel-2.6.35.14-106.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kernel-2.6.35.14-106.fc14

Comment 21 Fedora Update System 2011-11-29 00:21:43 UTC
kernel-2.6.35.14-106.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.