This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 64195 - Postfix does not provide /usr/bin/newaliases
Postfix does not provide /usr/bin/newaliases
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: postfix (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-28 14:08 EDT by John Eckerdal
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-28 14:08:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Eckerdal 2002-04-28 14:08:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
The Postfix RPM does not provide /usr/bin/newaliases making it impossible to use
with all RPMs (in this case mailman). There is
a specific /usr/bin/newaliases.postfix provided in the RPM just like it is in
sendmail (/usr/bin/newaliases.sendmail) but the sendmail RPM also provides
/usr/bin/newaliases (although it is not present as a file in the RPM - I guess
it is post-install script that is running or something).

I do not wish to install both Postfix and sendmail to be able to
use mailman it might cause confusion and it takes up disk space.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm -Uvh mailmain-x.i386.rpm postfix-x.i386.rpm
2.
3.
	

Actual Results:  Can't install mailman because of the dependancy problem.

Expected Results:  That I should be able to install mailman.

Additional info:

Same problem exists in the Raw Hide Postfix RPM.
Comment 1 Chris Ricker 2002-06-09 19:08:27 EDT
This is fixed in RHL 7.3 -- the alternatives magic to generate a symbolic link
from /usr/bin/newaliases.postfix to /usr/bin/newaliases is now done.

Note You need to log in before you can comment on or make changes to this bug.