Bug 642092 - Shotwell .desktop files are not translated in FC14 beta
Summary: Shotwell .desktop files are not translated in FC14 beta
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: shotwell
Version: 14
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Michel Alexandre Salim
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-11 23:47 UTC by Lucas Beeler
Modified: 2011-03-28 19:22 UTC (History)
5 users (show)

Fixed In Version: shotwell-0.8.1-2.fc14
Doc Type: Bug Fix
Doc Text:
See upstream bug http://trac.yorba.org/ticket/2661
Clone Of:
Environment:
Last Closed: 2011-03-22 03:47:26 UTC


Attachments (Terms of Use)

Description Lucas Beeler 2010-10-11 23:47:46 UTC
In Shotwell 0.7.2 as included in the FC14 beta, the GNOME desktop description files shotwell.desktop and shotwell-viewer.desktop in /usr/share/applications contain only US English strings, when they should contain strings for all 41 supported Shotwell languages.

The user-visible effect of this is that for all non-US English users, when they go to the main GNOME "Applications" menu and select "Graphics", they see an English descriptive string ("Shotwell Photo Manager") instead of a string in their native language. To observe this, simply log out of Fedora, set your language preference to any language other than US English, log back in, open the "Applications" > "Graphics" menu and note that the Shotwell descriptive string is in English regardless of whatever desktop language you're using.

This language mismatch does not happen when you download a Shotwell source tarball from the upstream developer at http://www.yorba.org/shotwell/install/, and then build and install Shotwell from source by typing

$ su
# ./configure --prefix=/usr
# make
# make install

(this is the standard way of building Shotwell from source on Fedora)

Since Shotwell builds and installs correctly from a raw tarball but isn't correctly installed by default, this may be a packaging issue.

Comment 1 Lucas Beeler 2010-10-11 23:52:33 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
See upstream bug http://trac.yorba.org/ticket/2661

Comment 2 Michel Alexandre Salim 2011-03-17 23:57:56 UTC
I've identified the problem and notified upstream:


"The problem is that gettext always returns the original string untranslated, if LANG=C. And guess what rpm sets LANG to when doing a build?

Not sure what the proper fix for this is. We're currently working around it by setting LANG=en_US.utf8 before 'make install'. That seems to do the trick."

Updated builds for F-15 and F-14 will follow shortly.

Comment 3 Fedora Update System 2011-03-18 00:45:40 UTC
shotwell-0.8.90-2.r2758.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/shotwell-0.8.90-2.r2758.fc15

Comment 4 Fedora Update System 2011-03-18 00:49:35 UTC
shotwell-0.8.1-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/shotwell-0.8.1-2.fc14

Comment 5 Fedora Update System 2011-03-22 03:47:16 UTC
shotwell-0.8.90-2.r2758.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2011-03-28 19:22:32 UTC
shotwell-0.8.1-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.