This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 642108 - Xen does not boot on ASUS A8N-E motherboard
Xen does not boot on ASUS A8N-E motherboard
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-11 22:46 EDT by W. Michael Petullo
Modified: 2010-10-18 01:38 EDT (History)
7 users (show)

See Also:
Fixed In Version: xen-4.0.1-6.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-18 01:38:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Photograph of failed boot (417.50 KB, image/jpeg)
2010-10-11 23:13 EDT, W. Michael Petullo
no flags Details

  None (edit)
Description W. Michael Petullo 2010-10-11 22:46:48 EDT
Description of problem:
Xen is not booting on a system with an ASUS A8N-E motherboard. The boot process seems to fail before Dom0 is loaded.

Version-Release number of selected component (if applicable):
Xen 4.0.1

How reproducible:
Every time

Steps to Reproduce:
1. Install Xen and a Dom0 kernel on a system with an A8N-E motherboard
2. Boot the system
  
Actual results:
Boot process fails with "IO-APIC + timer doesn't work!" Booting with "noacpi numcpus=0" allows the system to boot but results in an unstable Dom0 kernel.

Expected results:
The system should boot.

Additional info:
Comment 1 W. Michael Petullo 2010-10-11 23:13:16 EDT
Created attachment 452849 [details]
Photograph of failed boot
Comment 2 Michael Young 2010-10-12 04:48:23 EDT
Which xen package version did you see this with? There were some changes between xen-4.0.1-1.fc14 and xen-4.0.1-4.fc14 that might have had affect this issue (don't use xen-4.0.1-3.fc14).
Comment 3 W. Michael Petullo 2010-10-12 12:04:48 EDT
The package I have been using is xen-4.0.1-4.fc14.x86_64.
Comment 4 W. Michael Petullo 2010-10-12 12:14:42 EDT
I also tried xen-4.0.1-1.fc14.x86_64 and that package had the same problem.
Comment 5 Michael Young 2010-10-12 12:31:26 EDT
It looks like a known upstream bug, see
http://lists.xensource.com/archives/html/xen-devel/2010-09/msg00817.html
It looks like a patch for it is in the test queue for 4.0.x
http://xenbits.xen.org/staging/xen-4.0-testing.hg?rev/f7d54e1d7044
but not yet in the "will be in the next 4.0.x" queue
http://xenbits.xensource.com/xen-4.0-testing.hg
Comment 6 W. Michael Petullo 2010-10-12 13:13:38 EDT
The patch at http://xenbits.xen.org/staging/xen-4.0-testing.hg?rev/f7d54e1d7044 fixes the problem. Could we add this patch to the Fedora package until it is upstream?
Comment 7 Michael Young 2010-10-12 18:18:47 EDT
There is a build (xen-4.0.1-6.fc14) with the patch in koji at
http://koji.fedoraproject.org/koji/buildinfo?buildID=200238
Comment 8 W. Michael Petullo 2010-10-12 18:40:16 EDT
I just tested xen-4.0.1-6.fc14 and it works fine.
Comment 9 Fedora Update System 2010-10-14 10:12:10 EDT
xen-4.0.1-6.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xen-4.0.1-6.fc14
Comment 10 Fedora Update System 2010-10-15 00:07:46 EDT
xen-4.0.1-6.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xen'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/xen-4.0.1-6.fc14
Comment 11 Fedora Update System 2010-10-18 01:38:11 EDT
xen-4.0.1-6.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.