Bug 642118 - unicap.h uses "private" keyword as variable name
Summary: unicap.h uses "private" keyword as variable name
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libunicap
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kamil Dudka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 647320
TreeView+ depends on / blocked
 
Reported: 2010-10-12 04:51 UTC by Rich Mattes
Modified: 2010-11-18 17:21 UTC (History)
2 users (show)

(edit)
Clone Of:
: 647320 (view as bug list)
(edit)
Last Closed: 2010-10-22 18:03:00 UTC


Attachments (Terms of Use)

Description Rich Mattes 2010-10-12 04:51:13 UTC
Description of problem:
When compiling a C++ program with unicap.h, the following error occurs:

/usr/include/unicap/unicap.h:218:34: error: expected unqualified-id before ‘private’
/usr/include/unicap/unicap.h:218:34: error: expected ‘;’ before ‘private’

Upon further inspection, line 218 of unicap.h contains the following:
   unicap_data_buffer_private_t *private;

The "private" C++ keyword is being used here as a member name inside of a struct, which is preventing g++ from using unicap.h

Version-Release number of selected component (if applicable):
libunicap-0.9.12-1.fc14.x86_64
libunicap-devel-0.9.12-1.fc14.x86_64


How reproducible:
Compile a C++ program with unicap.h included.


Steps to Reproduce:
1. Create file "unicaptest.cpp" with trivial program:
  #include "unicap.h"
  int main(){}
2. Run g++ `pkg-config --cflags libunicap` -o unicaptest unicaptest.cpp
3. View error.
  
Actual results:
Program fails to compile, with above error

Expected results:
Program compiles 

Additional info:
Test case compiles when the file extension is changed to .c and gcc is used.

Comment 1 Kamil Dudka 2010-10-12 07:14:55 UTC
Thank you for filing the bug.  It seems to be already reported upstream, although on a completely wrong place:

https://bugs.launchpad.net/unicap/+bug/656229/comments/3

Comment 2 Kamil Dudka 2010-10-12 11:35:21 UTC
fixed in libunicap-0.9.12-4.fc15

Comment 3 Fedora Update System 2010-10-12 12:36:40 UTC
libunicap-0.9.12-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/libunicap-0.9.12-2.fc14

Comment 4 Fedora Update System 2010-10-12 12:37:07 UTC
libunicap-0.9.12-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/libunicap-0.9.12-2.fc13

Comment 5 Fedora Update System 2010-10-13 06:10:55 UTC
libunicap-0.9.12-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libunicap'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/libunicap-0.9.12-2.fc14

Comment 6 Kamil Dudka 2010-10-13 09:50:18 UTC
upstream bug:

https://bugs.launchpad.net/unicap/+bug/658739

Comment 7 Fedora Update System 2010-10-22 18:02:46 UTC
libunicap-0.9.12-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2010-10-28 05:53:32 UTC
libunicap-0.9.12-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2010-10-29 22:31:30 UTC
libunicap-0.9.12-5.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/libunicap-0.9.12-5.fc12

Comment 10 Fedora Update System 2010-10-29 22:31:34 UTC
libunicap-0.9.12-5.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/libunicap-0.9.12-5.el5

Comment 11 Fedora Update System 2010-11-02 16:05:45 UTC
libunicap-0.9.12-6.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/libunicap-0.9.12-6.fc12

Comment 12 Fedora Update System 2010-11-02 16:06:54 UTC
libunicap-0.9.12-7.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/libunicap-0.9.12-7.el5

Comment 13 Fedora Update System 2010-11-10 21:45:55 UTC
libunicap-0.9.12-6.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2010-11-18 17:21:05 UTC
libunicap-0.9.12-7.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.