Bug 64213 - ifconfig TX/RX bytes counter overflowing
ifconfig TX/RX bytes counter overflowing
Status: CLOSED DUPLICATE of bug 55953
Product: Red Hat Linux
Classification: Retired
Component: net-tools (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2002-04-29 08:41 EDT by Need Real Name
Modified: 2015-03-04 20:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-04-29 08:41:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-04-29 08:41:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
The transmit and receive bytes counters displayed by ifconfig when given no 
arguments reset to zero somewhere above 4077 MB, possibly at the 32-bit 
unsigned integer limit of 4,294,967,295.  The packet counters do not reset, as 
they should not.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Create lots of network traffic, the iperf program makes this easy.
2. Run ifconfig repeatedly during the test
3. Wait for just over 4 gigs worth of data to be transmitted and you'll see 
the TX and/or RX byte counter reset to zero.

Actual Results:  TX and RX bytes reset to zero ever 4 GB or so of data 

Expected Results:  TX and RX bytes should continuously climb as TX and RX 
packets do.

Additional info:
Comment 1 Phil Knirsch 2002-04-29 08:48:12 EDT

*** This bug has been marked as a duplicate of 55953 ***

Note You need to log in before you can comment on or make changes to this bug.