Bug 642229 - Visual indicator representing unsaved data is not displayed while editing data
Visual indicator representing unsaved data is not displayed while editing data
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI, Usability (Show other bugs)
4.0.0
All All
unspecified Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
: Improvement
Depends On:
Blocks: gwt-table-details jon3
  Show dependency treegraph
 
Reported: 2010-10-12 08:07 EDT by Sunil Kondkar
Modified: 2014-06-27 17:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-27 17:05:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sunil Kondkar 2010-10-12 08:07:09 EDT
Description of problem:

If user edits some data in a table say 'manage users' table, it does not display visual indicator representing that the current view has unsaved data.

Version-Release number of selected component (if applicable):
rhq build#401

How reproducible:

Always
Steps to Reproduce:

1) Login to JON using appropriate credential

2) Navigate to a table (Ex: Manage Users)

3) Double click on any of the row items.

4) Edit the user data 

5) Click 'Back to list' button without saving.
  
Actual results:

visual indicator representing unsaved data is not displayed

Expected results:

There should be some sort of visual indicator representing that the current view has unsaved data. Clicking the "save" button should persist changes made to the form, and clear this message.
Additional info:
Comment 1 Ian Springer 2011-02-15 11:36:01 EST
Once you click Back to List, any changes you made are thrown away. This was the intended behavior. If the user has unsaved changes and clicks Back to List, I'll add a confirm dialog that says "You have unsaved changes. Are you sure you want to abandon them and go back to the list?". Actually, I may not show the Back to List button at all if they are in edit mode, but rather just display a Cancel button at the bottom.
Comment 2 Jay Shaughnessy 2014-06-27 17:05:50 EDT
We have added this in many places, similar issues should be created in new, individual bzs.

Note You need to log in before you can comment on or make changes to this bug.