Bug 642268 - ip6tables-restore unable to initialize table 'filter'
ip6tables-restore unable to initialize table 'filter'
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iptables (Show other bugs)
5.6
All Linux
medium Severity medium
: rc
: ---
Assigned To: Thomas Woerner
qe-baseos-daemons
:
Depends On:
Blocks: 638638
  Show dependency treegraph
 
Reported: 2010-10-12 09:52 EDT by Alexander Todorov
Modified: 2014-10-01 13:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 08:48:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Boot screen screenshot (10.91 KB, image/png)
2011-12-12 13:18 EST, David Kovalsky
no flags Details

  None (edit)
Description Alexander Todorov 2010-10-12 09:52:07 EDT
Description of problem:
After fresh RHEL 5.6 install I get error when the system boots and starts the ip6tables service. 

Version-Release number of selected component (if applicable):
iptables-ipv6-1.3.5.-5.3.el5_4.1

How reproducible:
Always

Steps to Reproduce:
1. Perform an install of latest RHEL5.6
2. /etc/sysconfig/network contains NETWORKING_IPV6=no

3. Or service ip6tables start if it has been stopped.
  
Actual results:
When the system boots I get the message:

Applying ip6tables firewall rules: ip6tables-restore v1.3.5: ip6tables-restore: unable to initializetable 'filter'

Error occurred at line: 3
Try `ip6tables-restore -h' or 'ip6tables-restore --help' for more information.
                                                           [FAILED]

Expected results:
No error. 

Additional info:
Comment 1 Thomas Woerner 2010-10-19 06:30:14 EDT
The ip6tables init script does not have a check for ipv6. Therefore it is complaining because netfilter-v6 fails to initialize.

This is some kind of cosmetics, because there is no damage and ipv6 is not in use. If you disable ipv6 you can also disable the ip6tables service.
Comment 3 RHEL Product and Program Management 2011-05-31 11:24:54 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 5 David Kovalsky 2011-12-12 13:18:11 EST
Created attachment 545852 [details]
Boot screen screenshot
Comment 6 RHEL Product and Program Management 2014-03-07 07:43:12 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 7 RHEL Product and Program Management 2014-06-03 08:48:56 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).
Comment 8 James LEE 2014-10-01 13:51:14 EDT
hmm,
I think we can probably help you.
Be the links below .


http://pks-sme.blogspot.kr/2012/03/applying-ip6tables-firewall-rules.html

Note You need to log in before you can comment on or make changes to this bug.