Bug 64227 - dhcpcd continues to run after static configuration
dhcpcd continues to run after static configuration
Status: CLOSED DUPLICATE of bug 127726
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-29 15:40 EDT by Darren Gamble
Modified: 2014-03-16 22:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-24 13:42:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darren Gamble 2002-04-29 15:40:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
After configuring a DHCP-configured machine to use a static address, the dhcpcd 
client continues to run and overwrites the static information.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Configure a machine with DHCP (via /etc/network scripts) and perform 
a /etc/init.d/network restart .
2. Reconfigure the machine statically (via /etc/network scripts) and perform 
a /etc/init.d/network restart .
	

Actual Results:  The machine will revert back to its old configuration when the 
dhcp client (which shouldn't be running anymore) renews its lease.

Expected Results:  The machine should have kept its configuration.

Additional info:

We figured out what was going on after a few days and just killed the daemon 
manually.  But, this should be fixed for future releases.
Comment 1 Olivier Baudron 2002-06-12 14:06:57 EDT
The correct way of doing changes in a network configuration is:

1. /etc/init.d/network stop
2. Edit /etc/network scripts
3. /etc/init.d/network start

If you swap 1. and 2. you cannot properly stop daemons that were handling
interfaces...
Comment 2 Darren Gamble 2002-06-12 14:29:08 EDT
This procedure is unusable for many people including us- it's impossible to do 
unless you're physically located at the machine or have serial access.  I also 
don't see it documented anywhere on the Red Hat site.

If the stop scripts absolutely need a copy of the scripts as they started up 
with, then the best way to maintain consistancy (and thus fix this problem) is 
to have the network scripts create a copy of the configuration files that 
they'll use when the network is brought down again.

Or, one could just make sure dhcpcd is taken down when a "network stop" is 
done...
Comment 3 Aaron VanDevender 2005-03-24 12:26:38 EST
This bug still persists, and is triggered by using the system-config-network
program. I don't think its reasonable to expect anyone using
system-config-network to know they are supposed to service network stop before
they run the network config app. It also means remote network configuration
isn't possible with the system-config-network tool.

A quick and easy fix might be to have /etc/init.d/network check to see if
dhcp-client is running when start) is run and kill it if the interface is static.

The more "correct" approach would be to save two versions of
/etc/sysconfig/network[ing], one for what is currently running, and one for what
is currently desired. Then, in /etc/init.d/network, have stop) use the "running
version" of the configuration, and have start) copy the desired version over to
the running version.
Comment 4 Aaron VanDevender 2005-03-24 12:28:06 EST
Someone cooler than me (Bill?) should change the product to Fedora Core and the
Version to 3.
Comment 5 Bill Nottingham 2005-03-24 13:42:38 EST
This should be fixed in rawhide initscripts, as of 8.03-1.

*** This bug has been marked as a duplicate of 127726 ***

Note You need to log in before you can comment on or make changes to this bug.