Bug 64228 - X mouse overlay "shifts" right
X mouse overlay "shifts" right
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-29 16:29 EDT by Chris Ricker
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-10 13:41:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86 4.2 config file (3.72 KB, text/plain)
2002-05-03 11:23 EDT, Chris Ricker
no flags Details
log file for XFree86 (29.56 KB, text/plain)
2002-05-03 11:25 EDT, Chris Ricker
no flags Details

  None (edit)
Description Chris Ricker 2002-04-29 16:29:13 EDT
I'm seeing this on multiple systems (one system type is an AMD K6-III + Trident
Cyberblade laptop, not using the kernel Trident driver as it's horribly
unstable; one type is a dual Intel PII-366 with a Matrox G400; the third class
of machines are AMD Athlon 1700+ + Geforce 2), all with a fresh install of beta4
followed by up2date synchronization.

On all three types of systems, I'm using XFree86 4.

After running the systems in X for long periods of time, the mouse display is
"shifting" right.  What I mean by this is that the mouse cursor displays over
one location, but is interpreted by the X server as being over the same vertical
location, only to the right horizontally roughly 1/2 inch.

For example, if you look at the bottom of any bugzilla screen, it has a menu
that looks something like:

 Home |  News |  New Bug |  Query |  Help |  LogIn |  LogOut |  Errata  

If I put the mouse over Home and click, I get News; if I put the mouse over News
and click, I get the page for submitting a New Bug; if I put the mouse over New
Bug and click, I get the page for Query; and so forth.

This is not limited to mozilla.  I see the same thing within all other
applications, and within the window manager.

I've not been able to find any obvious cause of this.  It only occurs after long
periods of X use; starting multiple X servers on the same machine or using lots
of Java applications seems to encourage it.  I reproduce it most quickly by
starting up 2 X servers, then using Java applets in mozilla in both servers. 
This does not absolutely trigger it though, and it sometimes occurs w/o doing
all that.

This does not seem to be hardware specific (3 different video cards and mb
chipsets), and it's not window manager specific (I see it with both fluxbox and
KDE on all three types of systems).
Comment 1 Mike A. Harris 2002-04-30 05:22:12 EDT
Try adding to the device section of the config file:

Option "swcursor"

and see if that makes the problem go away.  If not, please attach 
your X config file and log file.  If this problem occurs on separate
video hardware, please open separate report for each one, as it sounds
like a video driver issue, which would make it card/driver specific, and
each problem would need to be resolved separately.  If it turns out to
be not hardware specific later, the reports can be closed as dupes.
Comment 2 Chris Ricker 2002-05-03 11:22:43 EDT
Reproduced in RH 7.3 gold w/ swcursor option enabled on a Trident Cyberblade.
Comment 3 Chris Ricker 2002-05-03 11:23:37 EDT
Created attachment 56287 [details]
XFree86 4.2 config file
Comment 4 Chris Ricker 2002-05-03 11:25:05 EDT
Created attachment 56288 [details]
log file for XFree86
Comment 5 Alan Hourihane 2002-05-03 13:15:11 EDT
Can you try starting X with

startx -- -nosilk
Comment 6 Chris Ricker 2002-05-05 11:52:17 EDT
Disabling Silken Mouse doesn't make a difference
Comment 7 Mike A. Harris 2002-08-07 04:43:56 EDT
I believe the current updated trident driver in rawhide fixes this.
Please reopen if problem persists, and we can try to troubleshoot further.

Thanks

Note You need to log in before you can comment on or make changes to this bug.