Bug 64235 - mount-2.11b-3 fails to return unavail automount and hangs/zombies
mount-2.11b-3 fails to return unavail automount and hangs/zombies
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-29 20:27 EDT by Need Real Name
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-20 11:41:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-04-29 20:27:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417

Description of problem:
With the RH 7.1 i386 mount upgrade package mount-2.11b-3, the request to
autmount an non-active mount hangs and refuses to time out.  If the request is
terminated by closing the terminal, the process zombies.  This is not present in
the distro package, mount-2.10r-5, or in the 7.2 package of simmilar build,
mount-2.11g-3.
Our automounts are distributed by NIS and have these mount options:
* -rw,hard,wsize=4096,rsize=4096,intr,bg

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.set up automounts as listed above
2.attempt to mount an unavailable server
3.request hangs w/o timeout
	

Expected Results:  Automount should time out, as it does with other packages.
This bug causes frequent crashes of our applications and we have had to remove
this package from all our servers as well as closely police our automounted
servers, negating many of the benefits of using automounts.

Additional info:
Comment 1 Elliot Lee 2002-06-20 11:41:49 EDT
NoClue on this...
Comment 2 Elliot Lee 2002-06-20 13:30:02 EDT
Since it works with the 7.2 package, all I can suggest is upgrading.

Note You need to log in before you can comment on or make changes to this bug.