This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 6424 - FTP install using updated bootnet/updates images fails
FTP install using updated bootnet/updates images fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-27 09:41 EDT by Lance A. Brown
Modified: 2015-01-07 18:39 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-29 14:18:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lance A. Brown 1999-10-27 09:41:36 EDT
System is a dual PIII Xeon system with 128 Meg memory and
two 18G Ultra2 drives attached to the onboard Adaptec 7896
SCSI controller.

Booted system from bootnet-RHEA-1999:044.img boot floppy,
selected FTP install using DHCP, system retreived 2nd stage
ramdisk from ftp server, asked for updates disk and properly
loaded it.

Proceeded with installation of 'custom system'.  Everything
went as normal until the 'Reading package information...'
box came up.  Immediately after, the following traceback
appeared:

Traceback (innermost last):
File "/usr/bin/anaconda.real", line 255, in ?
  intf.run(todo, test = test)
File "/tmp/updates/text.py", line 1009, in run
  rc = apply(step[1](),step[2])
File
"/mnt/redhat/comps/install/6.1/i386/misc/src/trees/hdimage/usr/lib/python1.5/site-packages/textw/packages.py",
line 10, in __call__
File "/tmp/updates.py", line 960, in getHeaderList
  selft.hdList = self.method.readHeaders()
File "/tmp/lib/python1.5/site-packages/urlinstall.py", line
45, in readHeaders url = urllib.urlopen(self.baseUrl +
"/RedHat/base/hdlist")
File "/tmp/lib/python1.5/urllib.py", line 59, in urlopen
  return _urlopener.open(url)
File "/tmp/lib/python1.5/urllib.py", line 157, in open
  return getattr(self,name)(url)
File "/tmp/lib/python1.5/urllib.py", line 370, in open_ftp
  self.ftpcache[key] = \
File "/tmp/lib/python1.5/urllib.py", line 559, in __inti__
  self.init()
File "/tmp/lib/python1.5/urllib.py", line 568, in init
  self.ftp.cwd(dir)
File "/var/tmp/python-root/usr/lib/python1.5/ftplib.py",
line 441, in cwd
File "/var/tmp/python-root/usr/lib/python1.5/ftplib.py",
line 233, in voidcmd
File "/var/tmp/python-root/usr/lib/python1.5/ftplib.py",
line 208, in voidresp
File "/var/tmp/python-root/usr/lib/python1.5/ftplib.py",
line 201, in getresp
IOError: [Errno ftp error] 550 i38: No such file or
directory.
Comment 1 Jay Turner 1999-10-29 14:18:59 EDT
This is actually an error which was generated by your FTP server . . .
at least that is what it looks like.  You might want to check and make
sure that the source files on the FTP server look good.  Granted the
installer should handle problems like this a little better, but a
little poking around should get you installing again.  Reopen if you
are still not able to determine the problem.
Comment 2 Lance A. Brown 1999-12-07 08:41:59 EST
I ran into this problem again while re-installing RH Linux 6.1 via FTP to the
same server above.  I received an identical traceback as well.

Further investigation revealed that this error was generated ONLY when I did NOT
place a leading '/' character on the path specification for the FTP server, i.e.

pub/redhat/redhat-6.1/i386

instead of

/pub/redhat/redhat-6.1/i386

With the leading slash the FTP install works fine.  Without it, I get the error
and traceback I originally submitted.

Note You need to log in before you can comment on or make changes to this bug.