Bug 64240 - fan and temperature controls don't work after apm -s on C810 and C640
fan and temperature controls don't work after apm -s on C810 and C640
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-04-30 01:11 EDT by Brian G. Anderson
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:39:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Brian G. Anderson 2002-04-30 01:11:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
On a fresh 'out of the box' Dell C810, the fan is off and only comes on
occasionally when the CPU heats up.  After issuing 'apm -s' the machine resumes,
but the fans are locked full on.  After installing i8kutil and loading i8k
module I can see that the CPU temperature readout from the BIOS is stuck at
85deg.  (I used ikmon to temporarilly shut the fan down, but it isn't a very
acceptable solution since the temp readout is screwed up)

I have done this on two C810 and both exhibited the same behavior: after apm -s
the fans are stuck on.  Before the apm -s the fans were fine.  Also I think this
behavior started after I upgraded apm to 3.0.2-9.

The final *very bad* result is the fans are stuck on always now.  Even shutting
down the machine and doing a full reboot will not clear it.  Once I turn the
machine on the fans come full on.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Get a fresh C810 and install beta2 with full upgrade
2.Notice the fans are working
3.Issue apm -s 
4.Notice the fans are locked on.

Additional info:

Like I said the severe problem is that I cannot clear the fans now.  They are
locked on straight from boot.  I was lucky to have to identical machines, but
now they are both in the same condition.  This is bad.
Comment 1 Brian G. Anderson 2002-04-30 14:06:18 EDT
I did some investigation and upgrading the BIOS from A05 to A07 clears the
problem.  Somehow the new version of apm aggrevated the old BIOS.  Anyway, the
workaround is to upgrade.

So a nice enhancement would be for redhat to ship i8kutil or equivalent.
Comment 2 Brian G. Anderson 2002-05-01 23:54:07 EDT
Well there is still no joy in Mudville.  The fan always on is cleared up, but if
I 'apm -s' and wait for a long time (over 1/2 hour) then upon restore the fans
will be locked on and i8kctl will report a CPU temperature of 85C.  The only way
to stop the fans is to reboot which will get the CPU temp working again.  Funny
thing is if I suspend for a short time, the temp will work on restore and the
fans will work fine.
Comment 3 Aleksey Nogin 2002-10-19 15:06:05 EDT
I have the same problem with Lattitude C640. If I suspend, keep it suspended for
a while and then resume, the temperature is stuck at 85C and both fans are stuck
on "high".

I disagree with "Severity: low" - first, this causes batteries to run out faster
and second, this makes my laptop really loud and I can not use it in the
environmewnt when I need to be quiet (lecture, etc).

P.S. Is this really an apmd bug? Or is it a kernel or BIOS one?
Comment 4 Aleksey Nogin 2002-11-02 21:47:12 EST
I was not able to reproduce this for a while. Could it be that loading the i8k
module on boot (in rc.local) prevents this from happening? Does anybody still
see this when i8k module is loaded?

What I see is that after long suspends that used to cause this, the fans will go
on high at resume and then go off right away - so it does enter the "bad" state,
as before, but something prevents it from staying in that state.
Comment 5 Bill Nottingham 2003-05-19 16:58:22 EDT
This is most likely an interaction between the kernel and the bios... I'm not
sure how you would fix this in apmd itself.
Comment 6 Brian G. Anderson 2003-05-19 19:35:50 EDT
Happens on a Dell 840 on the most recent BIOS levels.  Also it is time related:
if I suspend and the restore quickly all is fine.  If I suspend and wait an hour
then the fans are locked on high.

I haven't tried it with i8k.  I try it again with that module loaded.

Comment 7 Bugzilla owner 2004-09-30 11:39:32 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.