Bug 642442 - [RFE] Support hyphenated option variants (--ignoremonitoring vs --ignore-monitoring)
[RFE] Support hyphenated option variants (--ignoremonitoring vs --ignore-moni...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Petr Rockai
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-12 18:45 EDT by Petr Rockai
Modified: 2015-09-23 08:05 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-23 08:05:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Petr Rockai 2010-10-12 18:45:27 EDT
Hyphenated options are easier to read, so we should make them available and probably also advertise them by default. We still need to recognize the run-together versions of these options. Changes to the commandline parser infrastructure may be needed.
Comment 1 Milan Broz 2010-10-14 03:30:25 EDT
So these discussions about option naming are still ongoing?
Let's assign it to reporter which can of course fix it as well. :-]
Comment 2 Peter Rajnoha 2015-09-23 08:05:41 EDT
We have this since lvm2 v2.02.122.

LVM now removes any number of hyphens in the option name before processing it further, hence LVM always ends up looking at the option as if there were no hyphens at all.

Note You need to log in before you can comment on or make changes to this bug.