Bug 64245 - Wget does not like continue download and connection reuse
Wget does not like continue download and connection reuse
Product: Red Hat Linux
Classification: Retired
Component: wget (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Depends On:
  Show dependency treegraph
Reported: 2002-04-30 07:42 EDT by gsr.bugs
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-07-11 18:07:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description gsr.bugs 2002-04-30 07:42:27 EDT
Description of Problem:

I tried to download a file and had to stop it. Next time I had network
I used wget, this time with -c option to continue (otherwise it gets
from zero to a new file). The network became unstable, and there was a
timeout, so wget tried again, but complained that there was a problem
with "-c". So I wonder why the first try always work, but try 2 fails.

It seems related to "reusing connection", cos it does not happen when
"connecting" is printed (IOW, if for whatever reason it must reconnect,
wget can download partially downloaded files and do so with multiple
tries if needed).

Version-Release number of selected component (if applicable):

How Reproducible:

Always that -c is used with a partially downloaded file and there is
a time out, and the server is capable of keeping connections open.

Steps to Reproduce:
1. get part of a file from an Apache server, for example
2. continue the download with -c option
3. make the transfer stall so wget tries again, reusing the connection

Actual Results:
[error downloading an already partially downloaded file]

xx:xx:xx (x KB/s) - Read error at byte x/x (Connection timed out). Retrying.

--13:17:44--  http://x.x.x/x.x
  (try: 2) => `x.x'
Reusing connection to x.x.x.x:x.
HTTP request sent, awaiting response... 

Continued download failed on this file, which conflicts with `-c'.
Refusing to truncate existing file `xxx.x'.

And now the user has to launch wget again and pray that it can download
without more problems, or he will have to relaunch and relauch, instead
of using the max tries option.

Expected Results:

-c should work if the file was cut and the user wants to keep on
downloading. As is, -c is a pain with faulty servers or nets, cos
everytime there is a problem the user must relauch.

Additional Information:
In older versions the -c worked, probably cos there was no connection
reusing, or the interaction of reuse and partial was coded right. You
set a number of retries and it worked, not failed in the 2nd try, be
the file new or restarted from a partial download.
Comment 1 Trond Eivind Glomsrxd 2002-07-11 18:07:41 EDT
Is this still a problem with the version in RHL 7.3?
Comment 2 gsr.bugs 2002-07-11 18:30:59 EDT
Yes, seems so now, I have not saw it since I updated a couple weeks
or so ago. 1.8.1 seems fine, closing, if it reappears, I will open it

Note You need to log in before you can comment on or make changes to this bug.