Bug 64246 - reverse sub-domain delegation starting with 0 fails
reverse sub-domain delegation starting with 0 fails
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: bind (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-30 07:46 EDT by Pavel Urban
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-01 11:57:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Urban 2002-04-30 07:46:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
When I try to create reverse subdomain delegation beginning with '0', bind 
neither complains on loading, nor gives appropriate answer. Here is an example:

$TTL 86400
@       IN      SOA     dns.iol.cz.     hostmaster.iol.cz.      (
        2002043006      ;Serial
        10800           ;Refresh
        3600            ;Retry
        432000          ;Expire
        86000   )       ;Minimum
;
        IN      NS      dns.iol.cz.
        IN      NS      ns2.tel.cz.
;
0-26    IN      NS      nse.kr-karlovarsky.cz.
;
1       IN      CNAME   1.0-26.231.228.194.in-addr.arpa.
2       IN      CNAME   2.0-26.231.228.194.in-addr.arpa.

[root@dns named]# dig @127.0.0.1 0-26.231.228.194.in-addr.arpa. -t any

; <<>> DiG 9.2.0 <<>> @127.0.0.1 0-26.231.228.194.in-addr.arpa. -t any
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 19768
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;0-26.231.228.194.in-addr.arpa. IN      ANY

;; Query time: 28 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Tue Apr 30 13:42:36 2002
;; MSG SIZE  rcvd: 47

# but this one works fine...

[root@dns named]# dig @127.0.0.1 1.231.228.194.in-addr.arpa. -t any

; <<>> DiG 9.2.0 <<>> @127.0.0.1 1.231.228.194.in-addr.arpa. -t any
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 47496
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

;; QUESTION SECTION:
;1.231.228.194.in-addr.arpa.    IN      ANY

;; ANSWER SECTION:
1.231.228.194.in-addr.arpa. 86400 IN    CNAME   1.0-26.231.228.194.in-addr.arpa.

;; AUTHORITY SECTION:
231.228.194.in-addr.arpa. 86400 IN      NS      ns2.tel.cz.
231.228.194.in-addr.arpa. 86400 IN      NS      dns.iol.cz.

;; ADDITIONAL SECTION:
dns.iol.cz.             3600    IN      A       194.228.2.61
ns2.tel.cz.             86400   IN      A       194.228.2.1

;; Query time: 2 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Tue Apr 30 13:28:32 2002
;; MSG SIZE  rcvd: 143



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create reverse subdomain delegation in similar format as me
2. Try to resolve appropriate data (dig, nslookup)
3.
	

Additional info:
Comment 1 Pavel Urban 2002-05-01 02:25:31 EDT
It is getting even more weird... I've found another one.
$TTL 86400
@       IN       SOA     dns.iol.cz.  hostmaster.iol.cz. (
                                2002041120 ; Serial
                10800   ;Refresh
                3600    ;Retry
                432000  ;Expire
                86400 )  ;Minimum

        IN      NS      dns.iol.cz.
        IN      NS      ns2.tel.cz.
;

0       IN      NS        mail.jmahod.cz.
1       IN      CNAME   1.0.116.228.194.in-addr.arpa.

48       IN      NS       ns.rsts.cz.
48       IN      NS       ns2.tel.cz.

The first NS doesn't resolve, again (0.116 etc). BUT the second one does! 
(48.116...)
Comment 2 Pavel Urban 2002-05-01 11:57:41 EDT
Oops. My fault, but the bug (or feature?) looked so weird at the first glance, 
that I got desperate. The problem is somewhere else. When I try to dig my own 
server AND don't explicitely set '+norecursive', the server ignores its own 
database and asks other servers. Why, I still don't know, but the problem moved 
somewhere else. Sorry.
Comment 3 Pavel Urban 2002-05-02 06:42:33 EDT
According to bind developers, it IS a feature. Sorry again.

Note You need to log in before you can comment on or make changes to this bug.