This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 64248 - pcre header location is unusual
pcre header location is unusual
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: pcre (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-30 12:25 EDT by Moritz Barsnick
Modified: 2007-04-18 12:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-18 05:32:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moritz Barsnick 2002-04-30 12:25:31 EDT
Description of Problem:

The location of the pcre headers pcre.h and pcreposix.h, as delivered with the package pcre-devel, is a bit unusual. You place the headers in %{_includedir}/pcre/ instead of %{_includedir}/.

I have so far only come across software which searches for "pcre.h", non which requires "pcre/pcre.h" or provides a proper search macro for autoconf. I keep having to patch the autoconf stuff of those programs for them to compile.

According to http://rpmfind.net/, at least no other Linux pcre package (e.g. in other distributions) uses these paths.

I very much see the reason for separate header paths, especially with many header files, but not in this case. It's a bit strict, and furthermore, ot makes RedHat just this little bit more incompatible to everything else (if that's ever a reason).

Version-Release number of selected component (if applicable):

3.9-x (any package version of pcre in RedHat)

How Reproducible:

always

Steps to Reproduce:
1. check RedHat's pcre-devel package contents
2. 
3. 

Actual Results:

pcre.h and pcreposix.h are located in /usr/include/prce/.

Expected Results:

pcre.h and pcreposix.h should be located in /usr/include/.

Additional Information:
Comment 1 Joe Orton 2004-11-17 15:10:55 EST
This has been fixed for a while.

$ rpm -qf /usr/include/pcre/*.h
pcre-devel-4.5-3
pcre-devel-4.5-3
Comment 2 Joe Orton 2004-11-17 15:11:46 EST
Doh, I read this entire bug backwards :( Sorry.
Comment 3 Ngo Than 2004-11-18 05:32:40 EST
it's now fixed in pcre-5.0-1.
Comment 4 Dmitri A. Sergatskov 2005-04-13 11:09:16 EDT
Can we get the fix into FC3 as well? 
Comment 5 Joe Orton 2005-04-13 11:11:34 EDT
No, that would break compatibility. 
Comment 6 Dmitri A. Sergatskov 2005-04-13 11:14:57 EDT
Can we add symlinks
pcre.h -> pcre/pcre.h
pcreposix.h -> pcre/pcreposix.h

?

Comment 7 Moritz Barsnick 2005-04-13 11:25:32 EDT
Re comment #5 and comment #6:

I have built my own package "compat-pcre" (or something like this) which 
provides only these symbolic links. :) Perhaps this package is a candidate for 
FC3 Extras? Or shall I just provide it to everyone who asks?
Comment 8 Dmitri A. Sergatskov 2005-04-13 11:42:21 EDT
I opened the bug 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=154692
against FC3 as an enhancement request.

Note You need to log in before you can comment on or make changes to this bug.