Bug 642554 - rdesktop fails against certain Win 2008 Terminal Services with "disconnect: Internal licensing error"
rdesktop fails against certain Win 2008 Terminal Services with "disconnect: I...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rdesktop (Show other bugs)
5.6
All Linux
high Severity high
: rc
: ---
Assigned To: Søren Sandmann Pedersen
Desktop QE
: OtherQA, Patch
Depends On:
Blocks: 726826 836232 928849 831095
  Show dependency treegraph
 
Reported: 2010-10-13 06:23 EDT by ritz
Modified: 2014-06-18 05:13 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 744666 831095 (view as bug list)
Environment:
Last Closed: 2013-09-30 20:45:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ritz 2010-10-13 06:23:28 EDT
Description of problem:
rdesktop connections to certain Terminal Services fail
on the second connection (the first connection is successful).

Details:
- this only seems to happen when the TS is Win 2008 or Win 2008 R2 in
a "cluster" setup with licensing.

- Bugs are opened on the rdesktop Sourceforge site. A workaround is given:

> When I remove ~/.rdesktop/license.<hostname> I can connect ONLY ONE TIME,
> and after disconnect it fail again.

http://sourceforge.net/tracker/index.php?func=detail&aid=2803448&group_id=24366&atid=381347
http://sourceforge.net/tracker/index.php?func=detail&aid=2817779&group_id=24366&atid=381347

How reproducible:
100%

Steps to Reproduce:
Run rdesktop twice:

[root@lxslc5-amd64 ~]# ll ~/.rdesktop/
total 0
[root@lxslc5-amd64 ~]# rdesktop cerntsvmm
Autoselected keyboard map en-us
WARNING: Remote desktop does not support colour depth 24; falling back to 16
[root@lxslc5-amd64 ~]# ll ~/.rdesktop/
total 8
-rw------- 1 root root 2006 Sep 10 14:49 licence.lxslc5-amd64
[root@lxslc5-amd64 ~]# rdesktop cerntsvmm
Autoselected keyboard map en-us
disconnect: Internal licensing error.


Additional information:
 freerdp does not bother much with license ( discards them on program exit) , hence this issue is not seen with it. from freerdp/libfreerdp/freerdp.c int load_licence(unsigned char ** data) { return 0; } ... void save_licence(unsigned char * data, int length) { } 

Customer's configuration 
 - We have version of windows 2008 R2 (enterprise, not datacentre) 
 - We have CALS licenses per client 
 - License server contains Session Broker 
 - The cluster is configured in multicast, using port 3389: 


This issue is seen with upstream.
Comment 1 RHEL Product and Program Management 2011-05-31 10:48:10 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 7 J.H.M. Dassen (Ray) 2012-02-02 03:42:16 EST
A new upstream release <http://sourceforge.net/projects/rdesktop/files/rdesktop/1.7.1/> includes
"* Fix for per-device license mode on Windows 2008 R2 terminal server"

As best as I can tell, this refers to this specific change:
<http://rdesktop.svn.sourceforge.net/viewvc/rdesktop/rdesktop/trunk/licence.c?r1=1642&r2=1641&pathrev=1642&diff_format=u>. Setting keyword "Patch" accordingly.
Comment 8 J.H.M. Dassen (Ray) 2012-03-08 04:36:10 EST
(In reply to comment #7)
> As best as I can tell, this refers to this specific change:
> <http://rdesktop.svn.sourceforge.net/viewvc/rdesktop/rdesktop/trunk/licence.c?r1=1642&r2=1641&pathrev=1642&diff_format=u>.

This patch has been tested by my customer and they have confirmed it fixes this issue for them. Can we get a devel_ack for it please?
Comment 10 RHEL Product and Program Management 2012-06-11 21:25:38 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 13 Søren Sandmann Pedersen 2013-04-30 19:31:00 EDT
devel ack
Comment 21 Søren Sandmann Pedersen 2013-07-31 11:11:09 EDT
Build is here:

http://brewweb.devel.redhat.com/brew/taskinfo?taskID=6111027
Comment 25 errata-xmlrpc 2013-09-30 20:45:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1367.html

Note You need to log in before you can comment on or make changes to this bug.