Bug 64257 - libpthread.so: undefined reference to '-dl_cpuclock_offset'
libpthread.so: undefined reference to '-dl_cpuclock_offset'
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-30 15:37 EDT by elbert
Modified: 2016-11-24 10:18 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 15:08:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description elbert 2002-04-30 15:37:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; T312461)

Description of problem:

Undefined reference to '_dl_cpuclock_offset' from libpthread.so

I had similar problem with original distribution of glibc. The problem went 
away when I upgraded to glibc-2.2.4-19 level. This problem re-appears on latest 
glibc-2.2.4-24.

Version-Release number of selected component (if applicable):


How reproducible:

1. objdump -T libpthread.so
2. you should see the entry (_dl_cpuclock_offset) 

Always

Steps to Reproduce:
1.objdump -T /usr/lib/libpthread.so  > tst.txt 
2.There is an entry '_dl_cpuclock_offset' marks as undefined in tst.txt
3.
	

Additional info:
Comment 1 elbert 2002-04-30 17:08:35 EDT
problem occurs on glibc-2.2.4-24.i686.rpm only. problem goes away after 
reinstall glibc-2.2.4-24.i386.rpm
Comment 2 Jakub Jelinek 2002-05-01 07:39:14 EDT
This looks like you have a mixture of i386 and i686 libraries, particularly
that your /lib/ld-linux.so.2 comes from some .i386.rpm and /lib/i686/libpthread.so.0
or /lib/libpthread.so.0 comes from .i686.rpm.
_dl_cpuclock_offset is only defined in i686 /lib/ld-linux.so.2.
Before glibc 2.2.5 rpms due to some rpm bugs /lib/i686 was not always wiped
out when "upgrading" an older .i686.rpm with a newer .i386.rpm glibc.

Note You need to log in before you can comment on or make changes to this bug.