Bug 642599 - Used $http_server instead of $redhat_management_server
Used $http_server instead of $redhat_management_server
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
540
All Linux
high Severity high
: ---
: ---
Assigned To: Tomas Lestach
Garik Khachikyan
:
Depends On:
Blocks: sat54-errata
  Show dependency treegraph
 
Reported: 2010-10-13 08:23 EDT by Garik Khachikyan
Modified: 2015-01-04 16:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Kickstart variables have been updated, and correctly use the "$redhat_management_server" variable instead of "$http_server".
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-16 10:44:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garik Khachikyan 2010-10-13 08:23:16 EDT
Description of problem:
In the scopes of implementing Duplicate System Profiles (I think so) there was produced a part of script in kickstart file:
---
    if os.path.exists(old_system_id):
        client =  xmlrpclib.Server("http://<$http_server>/rpc/api")
        key = client.system.obtain_reactivation_key(open(old_system_id).read())
        f = open("/mnt/sysimage/tmp/key","w")
        f.write(key)
        f.close()
        shutil.copy(old_system_id, new_system_id)
---

Due to another bug (BZ#555212) seems that for clients it is common to use external KS tree through http, thus defining $http_server kickstart variable.

And in this case the process check wrongly will refer to (probably) not existing satellite call and will fail the logic.


Version-Release number of selected component (if applicable):
current sat540 iso: Satellite-5.4.0-RHEL5-re20101001.1

How reproducible:
always when specified $http_server in the kickstart variables

Steps to Reproduce:
1. prepare a kickstart profile
2. define http_server=<some-server> in the Variables of the kickstart (https://<sfqn>/rhn/kickstart/EditVariables.do?ksid=181)
3. 
  
Actual results:
in kickstart file there is written $http_server on that part of the script (see above)

Expected results:
$redhat_managemeny_server should be used IMO

Additional info:
Comment 2 Tomas Lestach 2010-11-18 10:27:22 EST
Fixed.
spacewalk.git: 368a4ed7f35a1bb538f04e93dc0d66ef87b7abb7
Comment 6 Garik Khachikyan 2010-12-07 10:17:26 EST
# VERIFIED

The following package(s) fixing the issue:
spacewalk-java-config-1.2.39-33.el5sat.noarch.rpm   
spacewalk-java-oracle-1.2.39-33.el5sat.noarch.rpm   
spacewalk-java-lib-1.2.39-33.el5sat.noarch.rpm   
spacewalk-taskomatic-1.2.39-33.el5sat.noarch.rpm   
spacewalk-java-1.2.39-33.el5sat.noarch.rpm

The scenario in comment#0 now works correctly - and fills with $redhat_managemeny_server value.
Comment 8 errata-xmlrpc 2010-12-16 10:44:59 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0991.html
Comment 9 Jaromir Hradilek 2010-12-16 11:33:34 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Kickstart variables have been updated, and correctly use the "$redhat_management_server" variable instead of "$http_server".

Note You need to log in before you can comment on or make changes to this bug.