This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 642641 - Chosing "Update existing resources" on the Collection Interval Metric Template doesn't completely work
Chosing "Update existing resources" on the Collection Interval Metric Templat...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core Server (Show other bugs)
1.4
All All
urgent Severity urgent (vote)
: ---
: ---
Assigned To: Filip Drabek
Corey Welton
:
Depends On:
Blocks: jon241-bugs jon30-bugs
  Show dependency treegraph
 
Reported: 2010-10-13 09:39 EDT by dsteigne
Modified: 2011-05-23 21:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-23 21:08:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description dsteigne 2010-10-13 09:39:09 EDT
Description of problem:

If you change Collection Intervals on the Metric Template (specifically for DataSources) and check the box "Update schedules for existing resources of marked type", it will update the values on the existing resources but nothing will collect at those intervals unless you manually update them on each resource's schedules tab

Version-Release number of selected component (if applicable):

2.4
Comment 1 Charles Crouch 2010-11-05 18:18:31 EDT
(10:02:35 AM) ccrouch: dsteigner: can you please elaborate on https://bugzilla.redhat.com/show_bug.cgi?id=642641
(10:02:35 AM) ccrouch: you say in the description that the update works, but then that it doesn't work?
(10:04:11 AM) dsteigner: ccrouch, doing it from the template updates the values on the individual resources, but it doesn't start collecting at those changed intervals
(10:04:37 AM) dsteigner: ccrouch-phone, until you actually change the value on each resource
(10:05:15 AM) mazz: I didn't see that behavior dsteigner - although I did restart my agents
(10:05:18 AM) mazz: its possible the sync isn't working 
(10:05:28 AM) ccrouch: dsteigner: so it just looks like it works
(10:05:35 AM) dsteigner: dsteigner, i didn't restart my agent
(10:05:37 AM) mazz: you changing the values on each resource probably worked because it changed the mtime on the resource which triggered a sync
(10:06:05 AM) dsteigner: ccrouch-phone, correct
(10:06:06 AM) mazz: we restarting the agent (but not changing each resource's value)
(10:06:09 AM) mazz: also triggers a sync
(10:06:29 AM) mazz: /we/me/
Comment 2 Charles Crouch 2010-11-09 19:07:06 EST
Filip
Please take a look at this and see if you can reproduce. This should be fixed in the release3 branch, but will also need to be fixed in Master. Lets target release3 (JON2.4.1) first.
Comment 4 Filip Drabek 2010-11-24 18:08:12 EST
commit 76f3d0dcaa6cad7c2491b86f2fd537a98ba56eaf in release-3.0 branch
Comment 5 Filip Drabek 2010-11-24 18:16:46 EST
commit 1bb8940ecd24eb3946d502fc84e6b648af72ffbb in master branch
Comment 6 Rajan Timaniya 2010-11-25 06:55:17 EST
Hi Filip,

Can you please provide steps to test the bug?
Comment 7 Filip Drabek 2010-12-09 09:14:11 EST
Repro steps:

1) Go to admin->settings->templates 
change Collection Intervals on the Metric Template (specifically for
DataSources) and check the box "Update schedules for existing resources of marked type
2) Check on each resource of selected type that the metrics are collected in the right intervals and that it reports the right values.
Comment 8 Sunil Kondkar 2010-12-10 06:07:02 EST
Verified on Jon241 build#38

Navigated to 'Administration->System Configuration->Templates and changed the collection interval on metric template for resources of type 'Datasource' from 10 minutes to 30 seconds. Checked the checkbox "Update schedules for existing resources of marked type".


Navigated to the resource JboassAs Server->Resources->Datasource->NoTxRHQDS   and
JboassAs Server->Resources->Datasource->RHQDS. Verified that the collection interval in changed from 10 minutes to 30 seconds in 'Schedules' tab and the metrics are collected at the correct interval of 30 seconds.
Comment 9 Corey Welton 2011-05-23 21:08:26 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.