Bug 642660 - Firstboot - inconsistent state when going "back" after registering
Firstboot - inconsistent state when going "back" after registering
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.1
All Linux
medium Severity high
: rc
: ---
Assigned To: Michael Stead
J.C. Molet
:
Depends On:
Blocks: rhsm-rhel62 743047
  Show dependency treegraph
 
Reported: 2010-10-13 10:17 EDT by Jeff Weiss
Modified: 2014-11-09 17:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:13:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
no back button (170.47 KB, image/png)
2011-09-26 10:43 EDT, J.C. Molet
no flags Details

  None (edit)
Description Jeff Weiss 2010-10-13 10:17:02 EDT
Description of problem:


Version-Release number of selected component (if applicable):
0.91-1

How reproducible:
Always

Steps to Reproduce:
1. Start firstboot
2. Register with candlepin
3. Now click Back

Actual results:
You're back on the registration form even though you are already registered.  The user can enter a new user/pw here and try to register again, which appears to succeed but is actually in a failed state.

Expected results:
We may want to consider unregistering the user when he clicks "Back" (perhaps with a "Are you sure you want to unregister?").  Because it's possible to register with candlepin, and use the back button to select RHN, and then proceed with RHN, and be registered with both RHN *and* Candlepin.  

Alternatively, we could have Back still show the register panel, but if you change user/pw it registers with --force (with a prompt, of course - should never use --force by default).  But then we'd need some way of preventing double registration with candlepin/RHN.   

Additional info:
My personal preference is option #1 above - make it impossible to register with both rhn and candlepin.
Comment 2 Michael Stead 2011-09-19 15:52:32 EDT
This was not fixed exactly as mentioned above. After some discussion, the decision was made to bypass the registration screen if the system was already registered, and to disable the back button once the user reaches the subscription manager screen.

Fixed in branches:
RHEL6.2 - 75a65f92580e74f26488d1bba5580550679f719a
master - e57d43303f5ca506c7b5df69a95ca471beb6fdde

NOTE
====
This fix does not apply to RHEL5 since there did not seem to be a way to access the back button in order to disable with the older version of firstboot.

739551 was created to keep track of this issue with 5.8.
Comment 4 J.C. Molet 2011-09-26 10:43:36 EDT
Created attachment 524924 [details]
no back button

python-rhsm-0.96.12-1.git.0.4862863.el6.noarch
subscription-manager-firstboot-0.96.11-1.git.7.15fc9d2.el6.x86_64
subscription-manager-0.96.11-1.git.7.15fc9d2.el6.x86_64
subscription-manager-gnome-0.96.11-1.git.7.15fc9d2.el6.x86_64

VERIFIED against the above version.

Screen shot shows that the back button is disabled once registered.  It also will skip the registration screen entirely if you are already registered when starting firstboot.
Comment 5 errata-xmlrpc 2011-12-06 12:13:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.