Bug 642763 - new user = blank/black wallpaper
new user = blank/black wallpaper
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F14Blocker-kde
  Show dependency treegraph
 
Reported: 2010-10-13 14:55 EDT by Rex Dieter
Modified: 2010-11-09 20:16 EST (History)
11 users (show)

See Also:
Fixed In Version: goddard-kde-theme-13.1.0-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-19 05:10:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2010-10-13 14:55:50 EDT
Something somewhere broke our default wallpaper recently, and Laughlin from plasma-desktop-appletsrc in kde-settings isn't getting used for new users.

Thinking that setting this via a plasma update script would perhaps be a better approach (bonus that it migrates upgraders to to new wallpaper too).  If we do go this route
Comment 1 nucleo 2010-10-13 16:26:01 EDT
I confirm this problem on Fedora 13 with KDE 4.5.2 installed from kde-testing.

But on LiveCD with kde 4.5.1 Fedora-14-Beta-i686-Live-KDE.iso
KDE starts with default wallpaper for new user with clean ~/.kde.
Comment 2 Kevin Kofler 2010-10-13 16:59:57 EDT
I think this change is what breaks using our preconfigured plasma-desktop-appletsrc: http://websvn.kde.org/?view=revision&revision=1169026
"backport: remove any stale config data to avoid accidentally merging old and existing containment configs"
Looks like this worked just by accident (at least since that 00-defaultLayout.js exists).

So that'd be why this changes with 4.5.2, should we try reverting that change as a quick hack? It's clearly not the correct fix though.
Comment 3 Sandro Mathys 2010-10-14 08:06:16 EDT
Not sure if this is the same problem or even no bug at all: as nucleo said the default wallpaper works on the livecd - but that's only true for the first monitor, i.e. the second is blank/black too.

Tested with F14 Final TC1.1 livecd (didn't try an installed system).
Comment 4 Rex Dieter 2010-10-14 09:28:04 EDT
It's new to 4.5.2 due to this commit,
http://websvn.kde.org/?view=revision&revision=1169026

So, here's the conversation I had in #plasma this morning,

[08:06] <rdieter> hi, with kde-4.5.2 we (in fedora) have found that our default plasma wallpaper no longer shows for new users, and think it may be due to http://websvn.kde.org/?view=revision&revision=1169026 , since we implemented it via /usr/share/config/plasma-desktop-appletsrc file.  any better suggestions on how to set a wallpaper for new users? (perhaps some javascript init/ or update/ script?)
[08:06] * aseigo adjusts a few things
[08:06] <aseigo> rdieter: yes, set it in the theme's metadata.desktop file
[08:07] <aseigo> the default theme's metadata.desktop file that is
[08:07] <aseigo> or move away from plasma-desktop-appletsrc and provide a proper javascript :)
[08:07] <rdieter> aseigo: oh neat, I'll look there thanks!
[08:07] <aseigo> either one will work
[08:07] <rdieter> (yeah, next idea was to try javascript)
[08:07] <aseigo> the javascript is probably the nice approach since you aren't carrying a patch then
[08:08] <aseigo> you really shouldn't be using plasma-desktop-appletsrc at all anymore for anything
[08:08] <rdieter> ok
[08:08] <aseigo> and if you are, ask me about it and i'll show you how to do it properly or implement support for whatever isn't possible :)
[08:09] <rdieter> i'm still learning the plasma/javascript coding bits.  there didn't seem to be an obvious way to set wallpaper there (short of the usual loop through all containments/widgets, and find the wallpaper item and use writeConfig)

[08:13] <rdieter> aseigo: pardon my ignorance, but when you say the theme's metadata.desktop file, do you mean the plasma theme or something else?  (I'm looking in default/metadata.desktop and oxygen/metadata.desktop and don't see any mention of wallpaper)
[08:13] <notmart> rdieter: plasma theme

[08:15] <rdieter> notmart: so what am I looking for?  all I see in all those metadata.desktop files are just Name=, Comment=, and X-KDE-PluginInfo-... keys.  nothing obviously related to wallpaper
[08:18] <notmart> rdieter: iirc it should have a[Wallpaper] section
[08:19] <notmart> and a defaultWallpaperTheme entry
[08:19] <aseigo> rdieter: the plasma theme, yes...
[08:19] <aseigo> rdieter: http://techbase.kde.org/Projects/Plasma/Theme#Wallpaper_Access
[08:19] <rdieter> grep -i wallpaper /usr/share/kde4/apps/desktoptheme/*/metadata.desktop  came up empty. ?
[08:19] <rdieter> ok, I'll do some reading
[08:19] * aseigo notes that we write documentation for a reason, we just need to get people to trust that we write documentation ;)
[08:20] <aseigo> rdieter: it's all of one paragraph, shouldn't take long :)
[08:20] <rdieter> aseigo: thanks for the handholding, I owe you (and google fail) :)
[08:21] <aseigo> rdieter: it's also possible to set the wallpaper plugin and mode via js, but the way to set the wallpaper settings is not as clear and obvious
[08:21] <aseigo> rdieter: what you need to do is ask for Wallpaper/<pluginname> from the config
[08:22] <aseigo> sth like:
[08:22] <aseigo> var wallpaperConfigPath = ['Wallpaper', 'image'];
[08:23] <aseigo> containment.currentConfigGroup = wallpaperConfigPath;
[08:23] <aseigo> hm.. or maybe shorter:
[08:23] <aseigo> containment.currentConfigGroup = ['Wallpaper', 'image']; // should work, but i haven't tested that :)
[08:23] <aseigo> and then you can do sth like:
[08:24] <aseigo> containment.writeConfig('wallpaper', 'ourFancyWalllpaper');
[08:24] * aseigo supposes it would be possible to add a writeWallpaperConfig method :)
[08:24] <aseigo> rdieter: would you find that useful?
[08:25] <aseigo> hm.. though wallpapers can have nested config as well..
[08:25] <rdieter> aseigo: maybe, though your suggestion already seems good enough to me
Comment 5 Rex Dieter 2010-10-14 09:35:59 EDT
More goodies to help write a script,
http://techbase.kde.org/KDE_System_Administration/PlasmaDesktopScripting
Comment 6 Rex Dieter 2010-10-14 10:55:35 EDT
OK, looks like making plasma themes to set the wallpaper is the way to go, will require adding stuff to laughlin-kde-theme (and goddard-kde-theme), and kde-settting mods to plasmarc to use those by default.
Comment 7 Kevin Kofler 2010-10-14 12:40:08 EDT
I really don't like that solution. :-(

This is yet another "let's take KDE's theme and customize 1 thing" "theme" like that Fedora-KDE icon theme we've finally gotten rid of. It also means that if you change to another Plasma theme, you lose the wallpaper and have to set it manually.
Comment 8 Fedora Update System 2010-10-14 12:45:33 EDT
goddard-kde-theme-13.1.0-1.fc13,fedora-logos-13.0.2-2.fc13,generic-logos-13.0.1-2.fc13,kde-settings-4.4-21.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/goddard-kde-theme-13.1.0-1.fc13,fedora-logos-13.0.2-2.fc13,generic-logos-13.0.1-2.fc13,kde-settings-4.4-21.fc13
Comment 9 Fedora Update System 2010-10-14 12:46:11 EDT
goddard-kde-theme-13.1.0-1.fc14,kde-settings-4.5-9.fc14,laughlin-kde-theme-14.0.0-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/goddard-kde-theme-13.1.0-1.fc14,kde-settings-4.5-9.fc14,laughlin-kde-theme-14.0.0-1.fc14
Comment 10 Fedora Update System 2010-10-15 00:08:01 EDT
goddard-kde-theme-13.1.0-1.fc14, kde-settings-4.5-9.fc14, laughlin-kde-theme-14.0.0-1.fc14, generic-logos-14.0.1-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update goddard-kde-theme kde-settings laughlin-kde-theme generic-logos'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/generic-logos-14.0.1-2.fc14,goddard-kde-theme-13.1.0-1.fc14,kde-settings-4.5-9.fc14,laughlin-kde-theme-14.0.0-1.fc14
Comment 11 Fedora Update System 2010-10-19 05:10:03 EDT
goddard-kde-theme-13.1.0-1.fc14, kde-settings-4.5-9.fc14, laughlin-kde-theme-14.0.0-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2010-11-09 20:16:41 EST
fedora-logos-13.0.2-2.fc13, generic-logos-13.0.1-2.fc13, goddard-kde-theme-13.1.0-1.fc13, kde-settings-4.4-21.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.