Bug 64277 - Problems with non ISO 8859-1 encoding
Problems with non ISO 8859-1 encoding
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-01 08:48 EDT by Hetz Ben Hamo
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-02 15:41:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hetz Ben Hamo 2002-05-01 08:48:48 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-9; Linux) 
 
Description of problem: 
When I try to open a GTK or QT app (up2date, kate - those are just examples) I 
get the following errors: 
 
 hetz]$ kate 
Qt: Locales not supported on X server 
 
hetz]$ up2date 
 
(up2date:21735): Gdk-WARNING **: locale not supported by Xlib 
 
(up2date:21735): Gdk-WARNING **: can not set locale modifiers 
 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Start X (no matter if GNOME, KDE or Window Maker) 
2. Try to run an application from the console 
3. see the results 
  
 
Actual Results:  posted above 
 
Expected Results:  Should work ;) 
 
Additional info: 
 
One of the other things that happends and can be seen with gfontsel - is that 
I see fonts names on the list (doesn't matter which encoding), but I cannot 
preview them - some of them, and even when previewed, I get errors like: 
 
Cannot open font: -monotype-arial-media-r-normal-*12-*-*-*-p-*-iso8859-8 (just 
an example) 
 
I'm not sure that it belongs to locale config or to XFree.. 
 
Hetz
Comment 1 Owen Taylor 2002-05-01 10:03:07 EDT
Probably an XFree bug, but there is some important information
missing here ... what locale are you trying to use? What
is the output of "echo $LANG"?
Comment 2 Owen Taylor 2002-05-01 10:08:17 EDT
Also, how did you set the locale? In the installer? Through
locale-config? Through GDM?
Comment 3 Hetz Ben Hamo 2002-05-01 10:18:12 EDT
For your first question:  
hetz]$ echo $LANG  
en_US.iso885915  
  
For the second question - I didn't try to change the localte - however I did 
select Hebrew and English on the beta4 installer. 
 
Comment 4 Owen Taylor 2002-05-01 10:36:19 EDT
Is this an upgrade from an earlier beta? We had some problems
with /etc/sysconfig/i18n being generated incorrectly earlier
by anaconda.

The immediate bug seems to be an X one

/usr/X11R6/lib/X11/locale/locale.alias has an alias

en.US.iso885915  en_US.ISO8859-15

But locale.dir in the same directory doesn't have an entry
for en_US.ISO8859-15. (Like locale.alias, this seems to
have every entry duplicated twice, once without the comma,
once with the comma, and probably requires both to 
be added.)


Comment 5 Jeremy Katz 2002-05-01 12:18:46 EDT
If this is a beta4 install, the various locale encodings weren't all there for
beta4, but they should all be fine for the final release.
Comment 6 Hetz Ben Hamo 2002-05-02 15:41:54 EDT
OK, updated to final RH 7.3 - bug seems to be gone. Please close this bug. 
 
Hetz 

Note You need to log in before you can comment on or make changes to this bug.