Bug 642826 - virt-resize converts any other image format to raw without notifying user, instructions do not account for this
virt-resize converts any other image format to raw without notifying user, in...
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-13 17:42 EDT by Adam Williamson
Modified: 2011-07-14 15:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-14 15:18:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2010-10-13 17:42:06 EDT
When resizing a disk image with virt-resize, the resulting image will be in raw format, no matter what format the input image was in. This is not explicitly called out in the output you get when using the tool or the manpage, and the instructions in the man page, if followed dumbly, fail to work because of this. The man page - http://libguestfs.org/virt-resize.1.html - in stage 6, 'Test', says to run 'virsh edit guestname' and then 'Change <source ...>', but it does not say to change the <driver> statement as well, which you will need to do unless the input image was also raw.

Possible solutions: output a disk image in the same format as the input image, or better document in the man page that the output image will always be in raw format, and add instructions to change the <driver> statement as well as the <source> statement in the machine definition.
Comment 1 Richard W.M. Jones 2010-10-14 03:50:59 EDT
This is actually a documentation bug.  You can create qcow2
from virt-resize by setting up a qcow2 container, eg:

qemu-img create -f qcow2 new.qcow 10G
virt-resize old.qcow new.qcow

(or even convert to/from qcow using this method).  However
since this is not in the documentation, no one knows about
it.

We will endeavour to fix this for 1.6.
Comment 2 Richard W.M. Jones 2010-10-18 08:36:14 EDT
Patch proposed upstream:
https://www.redhat.com/archives/libguestfs/2010-October/msg00031.html

Note You need to log in before you can comment on or make changes to this bug.