Bug 642836 - camera is not automounted by gvfsd
Summary: camera is not automounted by gvfsd
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gvfs
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tomáš Bžatek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-13 22:20 UTC by Christian Krause
Modified: 2015-03-03 22:53 UTC (History)
6 users (show)

Fixed In Version: gvfs-1.6.4-3.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-04 23:36:01 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 631562 None None None Never

Description Christian Krause 2010-10-13 22:20:56 UTC
Description of problem:
- camera (Canon A610) is not automounted anymore

Version-Release number of selected component (if applicable):
gvfs-gphoto2-1.6.4-2.fc14.i686


How reproducible:
100%

Steps to Reproduce:
1. attach camera via USB
  
Actual results:
- camera is not mounted via gvsfd

Expected results:
- camera should be mounted


Additional info:
- camera can be successfully detected by gphoto2:
$ gphoto2 --auto-detect
Model                          Port                                            
----------------------------------------------------------
Canon PowerShot A610 (PTP mode) usb:002,009     
$

- it is possible to manually mount it via gvfs:
gvfs-mount gphoto2://[ptpip:002009]

- I'm unsure whether this is a nautilus or gvfsd problem - please move the bug if necessary

Comment 1 Christian Krause 2010-10-16 21:29:46 UTC
I've debugged the issue and it looks like that the problem is, that libgphoto2 >= 2.4.10 explicitly requires the following syntax for USB-attached devices:
"usb:XXX,YYY" (with trailing zeros).

If gvfsd uses a syntax without trailing zeros like "usb:1,2" an internal check will fail in libgphoto's gp_camera_init function.

After my debugging I've seen that this bug was already reported upstream: https://bugzilla.gnome.org/show_bug.cgi?id=631562 . I've tested the patch attached to the upstream bug report and it solves the issue.

Please can you rebuild gvfs with this patch ( http://bugzilla-attachments.gnome.org/attachment.cgi?id=171853 ) applied? Thank you very much in advance!

Comment 2 Christian Krause 2010-10-24 19:43:39 UTC
Tomáš, Bastien, any news regarding this problem?

The bug is rather annoying (the whole gphoto2 integration of gvfs should be affected) and the suggested patch is very small (just one line) and non-invasive - IMHO there isn't any risk - even if upstream decide later to solve it otherwise.

If you don't have time and it would be OK with you I could quickly "provenpackage" it. Just let me know.

Thanks in advance!

Comment 3 Bastien Nocera 2010-10-28 16:29:10 UTC
I posted a better upstream patch, please test.

Comment 4 Christian Krause 2010-10-28 19:54:59 UTC
(In reply to comment #3)
> I posted a better upstream patch, please test.

This patch solves the problem as well - thanks for having a look at the issue!

Comment 5 Matthias Clasen 2010-10-29 21:24:31 UTC
Christian, now that we have the fix upstream, feel free to build a gvfs update with the patch. Otherwise, we'll pick it up with the next upstream release.

Comment 6 Fedora Update System 2010-11-01 15:40:36 UTC
gvfs-1.6.4-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gvfs-1.6.4-3.fc14

Comment 7 Fedora Update System 2010-11-02 22:15:29 UTC
gvfs-1.6.4-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gvfs'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/gvfs-1.6.4-3.fc14

Comment 8 Fedora Update System 2010-11-04 23:35:51 UTC
gvfs-1.6.4-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.