Bug 64288 - Cannot entitle registered systems
Summary: Cannot entitle registered systems
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server   
(Show other bugs)
Version: unspecified
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Chip Turner
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-01 19:02 UTC by Matt Jamison
Modified: 2007-07-31 19:15 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-01 21:22:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Josef Komenda 2002-05-01 19:02:30 UTC
Description of Problem: Cannot change entitlement on registered systems - have
100 workgroup on http://satellite.webdev-colo.redhat.com

but /network/entitlement/service_entitlements.pxt will not allow me to enable a
workgroup entitlement. 

Version-Release number of selected component (if applicable): see bug 63780

Comment 1 Greg DeKoenigsberg 2002-05-01 21:03:56 UTC
To be more specific: the entitlement option for Workgroup itself does not appear
in the pulldown -- although 100 available workgroup entitlements are listed.

The offending code:

    if ($pxt->user->org->has_entitlement('sw_mgr_enterprise')) {
      push @options,
        ([ 'None', 'none', $ent eq 'none' ? 1 : 0 ],
         [ 'Basic', 'sw_mgr_entitled', $ent eq 'sw_mgr_entitled' ? 1 : 0  ],
         [ 'Workgroup', 'enterprise_entitled', $ent eq 'enterprise_entitled' ? 1
: 0  ]);
    }
    else {
      push @options,
        ([ 'None', 'none', $ent eq 'none' ? 1 : 0 ],
         [ 'Basic', 'sw_mgr_entitled', $ent eq 'sw_mgr_entitled' ? 1 : 0  ]);
    }


...so it would appear that the entitlement certificate, although it populates
the count of workgroup systems properly, does not set the 'sw_mgr_enterprise'
flag properly -- whatever that flag is.

Comment 2 Chip Turner 2002-05-01 21:19:30 UTC
the problem was validate-sat-cert.pl didn't set this flag.  It should now.  the
data for rhnsat is fixed, and a new satellite-utils package has been uploaded.

Comment 3 Josef Komenda 2002-05-01 21:35:27 UTC
Fixed - closing.


Note You need to log in before you can comment on or make changes to this bug.