Bug 64289 - Cannot download RPMS
Cannot download RPMS
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bret McMillan
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-01 15:10 EDT by Matt Jamison
Modified: 2007-07-31 15:18 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-27 09:56:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josef Komenda 2002-05-01 15:10:35 EDT
Description of Problem: Added channel 'Red Hat Linux 7.2 i386'
http://satellite.webdev-colo.redhat.com/ , uploaded packages, and installed
rpms, but RPM's will not download - get 500 error and traceback. (See below)


Version-Release number of selected component (if applicable): See bug 63780

==========
Traceback:
==========

The following exception occured while executing this request:
 GET
/network/channel/download_isos.pxt/4Suite-0.11-2.i386.rpm?filename=rhn/NULL/4Suite/0.11-2/i386/4Suite-0.11-2.i386.rpm&pxt_trap=rhn:ftp_download_cb&token=c16e0150c1b6c40ca211ca86fe7be288x56549fb71a37e3c264215e9dbf85f99f&pxt_session_id=1xc1b4cb2821966f84071ab33280564b22&save_as=foo/4Suite-0.11-2.i386.rpm
HTTP/1.1 (from browser)
 /network/channel/download_isos.pxt/4Suite-0.11-2.i386.rpm (from Apache)

Date:
  Wed May  1 14:43:00 2002

Headers:
  Accept: text/xml, application/xml, application/xhtml+xml, text/html;q=0.9,
image/png, image/jpeg, image/gif;q=0.2, text/plain;q=0.8, text/css, */*;q=0.1
  Accept-Charset: ISO-8859-1, utf-8;q=0.66, *;q=0.66
  Accept-Encoding: gzip,deflate,compress,identity
  Accept-Language: en
  Connection: keep-alive
  Cookie: pxt_session=1xc1b4cb2821966f84071ab33280564b22;
rh_auth_token=1:1020278577x430c82f81b78a1cb2a926904c6e5dbc8
  Host: satellite.webdev-colo.redhat.com
  Keep-Alive: 300
  Referer:
http://satellite.webdev-colo.redhat.com/network/package/package_details.pxt?pid=40
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; Galeon) Gecko/20010901

Form variables:
  filename => rhn/NULL/4Suite/0.11-2/i386/4Suite-0.11-2.i386.rpm
  pxt_session_id => 1xc1b4cb2821966f84071ab33280564b22
  pxt_trap => rhn:ftp_download_cb
  save_as => foo/4Suite-0.11-2.i386.rpm
  token => c16e0150c1b6c40ca211ca86fe7be288x56549fb71a37e3c264215e9dbf85f99f

User Information:
  User joe_sat_1 (id 1, org_id 1)

Error notes:
  (none)

Initial Request:
  Yes

Error message:
  No X-Replace-Content header present; perhaps you aren't running behind an RHN
proxy? at /usr/lib/perl5/site_perl/5.6.1/i386-linux/Sniglets/Downloads.pm line 124.
Comment 1 Greg DeKoenigsberg 2002-05-01 17:21:12 EDT
To be specific: is this problem unique to the website?
Comment 2 Josef Komenda 2002-05-01 17:27:07 EDT
Yes - to be specific, you cannot download an RPM from the package details page:
/network/package/package_details.pxt

Comment 3 Bret McMillan 2002-05-23 10:10:59 EDT
Fixed in HEAD and RELEASE-1_9_1 branches.

/me punts to QA.
Comment 4 Josef Komenda 2002-06-19 17:22:39 EDT
Have removed this functionaliy from the satellite package details page, but the
/network/packagelist/download_packages.pxt also does not work. We may want to
disable the download packge functionalaity altogether by removing the big red
download button from the package list pages at:
 /network/system/system_outdated_package_list.pxt
 /network/channel/channel_packages.pxt
 /network/system/install_packages.pxt
and any others I overlooked.
Comment 5 Josef Komenda 2002-06-25 11:11:19 EDT
Now that rhns-satellite-sync is working, the rpm's are showing upon the package
details page, but they give a 400 error when you click on them.
Comment 6 Chip Turner 2002-06-26 11:42:07 EDT
this is bretm's now
Comment 7 Bret McMillan 2002-06-26 13:04:37 EDT
I'm not getting any 400's on the packages in the "joe chan" channel, nor any I
pick on the 7.1 or 7.2 channels.

This seems to be fixed.  Was an import problem, or webcode problem?
Comment 8 Josef Komenda 2002-06-26 15:20:21 EDT
Correction - 500 Error - Internal Server Error. Methinks a hotfix took place on
satellite.webdev-colo. Try satcd.rud.redhat.com.
Comment 9 Josef Komenda 2002-06-27 13:37:16 EDT
Fixed - Closing.

Note You need to log in before you can comment on or make changes to this bug.