This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 642892 - "Group Definition" link for an individual dynagroup's view should take user to Dynagroups page or Edit page - not main Groups View
"Group Definition" link for an individual dynagroup's view should take user t...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
1.4
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
:
Depends On:
Blocks: rhq4 gwt-groups
  Show dependency treegraph
 
Reported: 2010-10-13 23:37 EDT by Corey Welton
Modified: 2011-05-23 21:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2010-10-13 23:37:14 EDT
Description of problem:
The link provided in the view for any given Dynagroup takes user back to the overall group view.  This doesn't seem to make much sense in the context.  It would make more sense to take user to list view of all dynagroups, or perhaps even that dynagroup's edit definition page.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Create a [compatible] dynagroup
2.  Navigate to Inventory > Groups > Compatible Groups 
3.  Click on the name of your dynagroup
4.  On the resulting page, note the link for "Group Definition:"; click it.


Actual results:
User is taken back to the All Groups view

Expected results:
This link should take user to somewhere a little more contextually appropriate, esp. since this link only appears on Dynagroups.  I'd recommend it take user to either the Dynagroups view (Inventory > Dynagroup Manager) or to the edit definition page for the dynagroup itself.


Additional info:
Comment 1 John Mazzitelli 2011-02-17 15:06:48 EST
takes you to the dynagroup details page now
Comment 2 Corey Welton 2011-03-29 11:58:45 EDT
QA Verified.
Comment 3 Corey Welton 2011-05-23 21:17:30 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 4 Corey Welton 2011-05-23 21:17:30 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 5 Corey Welton 2011-05-23 21:17:30 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 6 Corey Welton 2011-05-23 21:17:30 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.