Bug 64300 - KDE 3.0: kded core dumps (SIGABRT) when saving session at logout
Summary: KDE 3.0: kded core dumps (SIGABRT) when saving session at logout
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdelibs (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
high
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-01 21:40 UTC by Stefan Teleman
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-25 19:55:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gziped core dump file (242.78 KB, application/octet-stream)
2002-05-01 21:45 UTC, Stefan Teleman
no flags Details

Description Stefan Teleman 2002-05-01 21:40:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-31 i686)

Description of problem:
I am using KDE3.0 the stable rpm download binary on an IBM ThinkPad A20P with
512MB RAM running RedHat 7.2 (2.4.9-31). kded catches SIGABRT and dumps core
every time i logout and save my session. I am attaching the core dump file. I
will try to compile KDE3.0 from source with -g and hopefully get more
information as to where exactly this happens -- so far, gdb told me that it is
happening in libkdecore.so.4 -> kDebugBackend() -> libc.so.6 -- it looks like
something raises an uncaught exception.

Version-Release number of selected component (if applicable): 3.0


How reproducible:
Always

Steps to Reproduce:
1. Login to a kde3 session.
2. Choose "Logout".
3. Choose "Yes" when asked to save the session for future logins.
	

Additional info:

Comment 1 Stefan Teleman 2002-05-01 21:45:06 UTC
Created attachment 56084 [details]
gziped core dump file

Comment 2 Ngo Than 2002-11-30 19:12:25 UTC
Hmm, as i know the RHL 7.2 had kde 2.2.x. We don't have released KDE 3.0 for 7.2.

i don't fix a bug in package, which has not been built by Red Hat.

I close this bug as wont fix.


Note You need to log in before you can comment on or make changes to this bug.