Bug 64302 - python2 distutils.core broken, depends on python2-devel
python2 distutils.core broken, depends on python2-devel
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: python2 (Show other bugs)
skipjack-beta2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-01 18:46 EDT by Daniel Resare
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-31 09:40:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Resare 2002-05-01 18:46:07 EDT
Description of Problem:
any simple setup script (setup.py) will fail when invoked with python2

Version-Release number of selected component (if applicable):
python2-2.2-16 (skipjack-2 + up2date updates)

How Reproducible:
always

Steps to Reproduce:
1. fetch a package with a setup.py script (for example
http://prdownloads.sourceforge.net/mimelib/email-2.0.1.tar.gz)
2. run 'python2 setup.py install


Actual Results:
Traceback (most recent call last):
  File "setup.py", line 19, in ?
    packages=['email'],
  File "/usr/src/build/87651-i386/install/usr/lib/python2.2/distutils/core.py",
line 138, in setup
  File "/usr/src/build/87651-i386/install/usr/lib/python2.2/distutils/dist.py",
line 893, in run_commands
  File "/usr/src/build/87651-i386/install/usr/lib/python2.2/distutils/dist.py",
line 912, in run_command
  File "/usr/lib/python2.2/cmd.py", line 112, in ensure_finalized
    
  File
"/usr/src/build/87651-i386/install/usr/lib/python2.2/distutils/command/install.py",
line 268, in finalize_options
  File
"/usr/src/build/87651-i386/install/usr/lib/python2.2/distutils/sysconfig.py",
line 408, in get_config_vars
  File
"/usr/src/build/87651-i386/install/usr/lib/python2.2/distutils/sysconfig.py",
line 313, in _init_posix
distutils.errors.DistutilsPlatformError: invalid Python installation: unable to
open /usr/lib/python2.2/config/Makefile (No such file or directory)


Expected Results:
program installation :)

Additional Information:
Comment 1 Trond Eivind Glomsrxd 2002-05-01 19:11:26 EDT
Works here... email-2.0.1:

[root@halden email-2.0.1]# python2 setup.py install
running install
running build
running build_py
creating build
creating build/lib
creating build/lib/email
copying email/Charset.py -> build/lib/email
copying email/Encoders.py -> build/lib/email
copying email/Errors.py -> build/lib/email
copying email/Generator.py -> build/lib/email
copying email/Header.py -> build/lib/email
copying email/Iterators.py -> build/lib/email
copying email/MIMEAudio.py -> build/lib/email
copying email/MIMEBase.py -> build/lib/email
copying email/MIMEImage.py -> build/lib/email
copying email/MIMEMessage.py -> build/lib/email
copying email/MIMEText.py -> build/lib/email
copying email/Message.py -> build/lib/email
copying email/Parser.py -> build/lib/email
copying email/Utils.py -> build/lib/email
copying email/__init__.py -> build/lib/email
copying email/base64MIME.py -> build/lib/email
copying email/quopriMIME.py -> build/lib/email
running install_lib
creating /usr/lib/python2.2/site-packages/email
copying build/lib/email/Charset.py -> /usr/lib/python2.2/site-packages/email
copying build/lib/email/Encoders.py -> /usr/lib/python2.2/site-packages/email
copying build/lib/email/Errors.py -> /usr/lib/python2.2/site-packages/email
copying build/lib/email/Generator.py -> /usr/lib/python2.2/site-packages/email
copying build/lib/email/Header.py -> /usr/lib/python2.2/site-packages/email
copying build/lib/email/Iterators.py -> /usr/lib/python2.2/site-packages/email
copying build/lib/email/MIMEAudio.py -> /usr/lib/python2.2/site-packages/email
copying build/lib/email/MIMEBase.py -> /usr/lib/python2.2/site-packages/email
copying build/lib/email/MIMEImage.py -> /usr/lib/python2.2/site-packages/email
copying build/lib/email/MIMEMessage.py -> /usr/lib/python2.2/site-packages/email
copying build/lib/email/MIMEText.py -> /usr/lib/python2.2/site-packages/email
copying build/lib/email/Message.py -> /usr/lib/python2.2/site-packages/email
copying build/lib/email/Parser.py -> /usr/lib/python2.2/site-packages/email
copying build/lib/email/Utils.py -> /usr/lib/python2.2/site-packages/email
copying build/lib/email/__init__.py -> /usr/lib/python2.2/site-packages/email
copying build/lib/email/base64MIME.py -> /usr/lib/python2.2/site-packages/email
copying build/lib/email/quopriMIME.py -> /usr/lib/python2.2/site-packages/email
byte-compiling /usr/lib/python2.2/site-packages/email/Charset.py to Charset.pyc
byte-compiling /usr/lib/python2.2/site-packages/email/Encoders.py to Encoders.pyc
byte-compiling /usr/lib/python2.2/site-packages/email/Errors.py to Errors.pyc
byte-compiling /usr/lib/python2.2/site-packages/email/Generator.py to Generator.pyc
byte-compiling /usr/lib/python2.2/site-packages/email/Header.py to Header.pyc
byte-compiling /usr/lib/python2.2/site-packages/email/Iterators.py to Iterators.pyc
byte-compiling /usr/lib/python2.2/site-packages/email/MIMEAudio.py to MIMEAudio.pyc
byte-compiling /usr/lib/python2.2/site-packages/email/MIMEBase.py to MIMEBase.pyc
byte-compiling /usr/lib/python2.2/site-packages/email/MIMEImage.py to MIMEImage.pyc
byte-compiling /usr/lib/python2.2/site-packages/email/MIMEMessage.py to
MIMEMessage.pyc
byte-compiling /usr/lib/python2.2/site-packages/email/MIMEText.py to MIMEText.pyc
byte-compiling /usr/lib/python2.2/site-packages/email/Message.py to Message.pyc
byte-compiling /usr/lib/python2.2/site-packages/email/Parser.py to Parser.pyc
byte-compiling /usr/lib/python2.2/site-packages/email/Utils.py to Utils.pyc
byte-compiling /usr/lib/python2.2/site-packages/email/__init__.py to __init__.pyc
byte-compiling /usr/lib/python2.2/site-packages/email/base64MIME.py to
base64MIME.pyc
byte-compiling /usr/lib/python2.2/site-packages/email/quopriMIME.py to
quopriMIME.pyc
[root@halden email-2.0.1]# rpm -q python2
python2-2.2-16
[root@halden email-2.0.1]#
Comment 2 Daniel Resare 2002-07-31 09:39:58 EDT
I was bitten again by this and took the time to find out the real problem. It
seems like python2-devel needs to be installed before distutils.core
functionality works. I think this is a bug since installing software is a normal
activity and quite different from compiling python extentions in c, that
python2-devel is used for otherwise.

So, please move /usr/lib/python2.2/config/Makefile from python2-devel to python2
as it is needed by at least distutils.core
Comment 3 Trond Eivind Glomsrxd 2002-07-31 10:30:48 EDT
Not a bug, you're working with python code.

Note You need to log in before you can comment on or make changes to this bug.