Bug 643042 - ks for virtual guest is not properly updated
Summary: ks for virtual guest is not properly updated
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades
Version: 540
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Milan Zázrivec
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard: Fixed in the 5.4.0 Release - GA'd 201...
Depends On:
Blocks: sat540-blockers sat540-upgrades
TreeView+ depends on / blocked
 
Reported: 2010-10-14 14:08 UTC by Petr Sklenar
Modified: 2010-11-30 09:43 UTC (History)
3 users (show)

Fixed In Version: rhn-upgrade-5.4.0.10-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-28 15:02:34 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Petr Sklenar 2010-10-14 14:08:27 UTC
Description of problem:
ks for virtual guest is not properly updated

Version-Release number of selected component (if applicable):
sat530 > sat540
os upgrade rhel4U8@i386 > rhel5@x86_64

How reproducible:
tried once

Steps to Reproduce:
1. create ks for virtual guest and add:
Virtual Memory (in MB):  533	
Number of Virtual CPUs: 3	
Virtual Disk Space (in GB): 	 5
Virtual Bridge: 	br0

2. upgrade satellite
3. ks is not the same:
Virtual Memory (in MB):  512	
Number of Virtual CPUs: 1	
Virtual Disk Space (in GB): 	 2
Virtual Bridge: 	virbr0

  
Actual results:
ks is not same in Memory, CPU, disk and bridge

Expected results:
ks is same

Additional info:

Comment 2 Milan Zázrivec 2010-10-14 14:13:32 UTC
Memory 512MB, number of cpus 1, disk space 2GB are the default values.

Not sure why the upgrade sets these to defaults ...

Comment 4 Milan Zázrivec 2010-10-15 10:16:51 UTC
The solution we agreed on here would be to copy over the kickstart
profiles from /var/lib/cobbler/config/profiles.d/ from the old Satellite
to the same location at the new Satellite.

Comment 5 Milan Zázrivec 2010-10-15 14:15:27 UTC
OK, after more testing & investigation:

When upgrading from Cobbler 1.6 to 2.0, we need to do two things:
1. Restore the original profiles from the old Satellite (if applicable)
2. Force cobbler to re-serialize the profile files from YAML to
JSON format.
    
We must not let tomcat / taskomatic to force cobbler to do the
re-serialization (which would normally happen during satellite restart),
since taskomatic would instruct cobbler to re-serialize the profiles with
default, *not* the original data.

There are now new instructions in rhn-upgrade and a new script called

    /etc/sysconfig/rhn/satellite-upgrade/upgrade-cobbler.sh

which will make cobbler reserialize the profile files on disk
from YAML to JSON format (i.e. the original data would be
preserved).

satellite.git master: 4d8c6d9d6047aa2fc6e9367b0b86e265e057b8c8

Comment 7 Clifford Perry 2010-10-28 15:02:34 UTC
The 5.4.0 RHN Satellite and RHN Proxy release has occurred. This issue has been resolved with this release. 


RHEA-2010:0801 - RHN Satellite Server 5.4.0 Upgrade
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10332

RHEA-2010:0803 - RHN Tools enhancement update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10333

RHEA-2010:0802 - RHN Proxy Server 5.4.0 bug fix update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10334

RHEA-2010:0800 - RHN Satellite Server 5.4.0
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10335

Docs are available:

http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/index.html 

Regards,
Clifford


Note You need to log in before you can comment on or make changes to this bug.