Bug 643173 - Group> Role assignment for LDAP groups will only list 1000 groups
Group> Role assignment for LDAP groups will only list 1000 groups
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Database (Show other bugs)
3.0.0
All All
high Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: jon30-bugs
  Show dependency treegraph
 
Reported: 2010-10-14 16:28 EDT by dsteigne
Modified: 2011-06-08 15:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-08 15:41:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dsteigne 2010-10-14 16:28:53 EDT
Description of problem:

When creating a Role and wanting to add Groups to the role the GUI will only list 1000 groups.  Most likely due to the Oracle 1000 IN Clause limitation.


Version-Release number of selected component (if applicable):

2.4
Comment 1 Charles Crouch 2010-10-18 11:58:29 EDT
We need to go back through the codebase *again* and make sure we've got all of these.
Comment 2 Charles Crouch 2010-11-01 21:00:32 EDT
Need to investigate if this is straightforward to fix in JON2.4.1. It will be of limited use however since adding filter/search feature to the ldap groups is out of scope for 2.4.1
Comment 3 Charles Crouch 2010-11-10 11:52:11 EST
Moving this to jon3.0. We don't blow up in this case right now, we are just limited to showing the first 1000groups. This is only going to be properly fixed when we add group search/filtering in 3.0
Comment 4 Charles Crouch 2011-03-31 19:11:49 EDT
As I said earlier I don't think the solution here is just to retrieve 10,000groups, but to allow better filtering/searching so you can actually find the probably at most 50 groups you are actually interested in. Setting needinfo on spinder so he can comment on what we have/could have here.
Comment 5 Simeon Pinder 2011-04-01 06:03:32 EDT
This was fixed for jon3.0 already to support filtering of ldap groups by name. See https://bugzilla.redhat.com/show_bug.cgi?id=643963.  I never looked into patching the JSF 2.4.1 code. Are we reconsidering modifying the JSF 2.4.1 code and should i look into this?
Comment 6 Charles Crouch 2011-06-08 15:41:15 EDT
If we've got a search filter in 3.0 then that should be sufficient

Note You need to log in before you can comment on or make changes to this bug.