This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 64320 - xemacs-21.4.6-8 missing requirements
xemacs-21.4.6-8 missing requirements
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-02 09:01 EDT by Ville Skyttä
Modified: 2007-03-26 23:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-07 16:04:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2002-05-02 09:01:58 EDT
Rawhide's xemacs-21.4.6-8 seems to be missing requirements. 
After an update from xemacs-21.4.6-7, here's what I get: 
[scop@bobcat scop]$ xemacs 
xemacs: error while loading shared libraries: libXm.so.3: cannot open shared object file: 
No such file or directory 
 
This is fixed by installing openmotif-2.2.2-5. 
There are certainly some other requirements missing from the xemacs RPM 
(the same problem occurs with libwnn.so.0, fixed by installing FreeWnn-libs), see: 
[scop@bobcat scop]$ rpm -qRp xemacs-21.4.6-8.i386.rpm 
info 
ctags 
rpmlib(VersionedDependencies) <= 3.0.3-1 
rpmlib(PayloadFilesHavePrefix) <= 4.0-1 
rpmlib(CompressedFileNames) <= 3.0.4-1 
 
However, "ldd /usr/bin/xemacs-21.4.6" lists pretty many libs... 
 
My system is RH7.2, with some parts updated from Rawhide.
Comment 1 Ville Skyttä 2002-05-02 09:06:42 EDT
Just verified that "rpm -qR" for xemacs-21.4.6-7.i386.rpm (the older version) gives the  
expected output with all shared libs listed.
Comment 2 Trond Eivind Glomsrxd 2002-05-06 19:03:25 EDT
Did you use nodeps? If the you didn't have the library and rpm let you install
it, that would be an rpm bug...
Comment 3 Ville Skyttä 2002-05-06 19:17:41 EDT
No, I didn't use --nodeps (because there are practically no dependencies in the xemacs 
RPM, so rpm didn't tell me to install what's needed).  
 
But please take another look at my previous comments, shouldn't "rpm -qRp 
xemacs-21.4.6-8.i386.rpm" print out a lot of dependencies for libs too, in addition to 
"info" and "ctags" and the "rpmlib" stuff?  At least "rpm -qRp 
xemacs-21.1.14-23.7.2.i386.rpm" (from 7.2 updates) does... 
 
Might still be an rpm bug, dunno?  I have rpm-4.0.4-7x from 7.2 updates installed.
Comment 4 Trond Eivind Glomsrxd 2002-05-07 15:04:43 EDT
(modified means "fixed, waiting for QA confirmation". Setting to assigned.)

It's a bug in rpm. The first three lines of one of the scripts in the package read:

: # -*-Perl-*-
eval 'exec perl -w -S $0 ${1+"$@"}' # Portability kludge
    if 0;

Rpm's find-requires thinks ":" is the interpreter, and bugs out completely,
losing  all other dependencies. 


xemacs-21.4.6-9 has a temporary workaround for this rpm bug (chmod -x this file).

Comment 5 Jeff Johnson 2002-05-07 15:19:51 EDT
Patch your script to put 
	#!/usr/bin/perl
at the beginning of the script.
Comment 6 Trond Eivind Glomsrxd 2002-05-07 16:04:46 EDT
The existing script works. The bug is in rpm - it getting confused in the first
place is a bug itself (although hard to fix), forgetting all other dependencies
is a much more severe bug.
Comment 7 Jeff Johnson 2002-05-09 10:47:56 EDT
The core issue is whether a build should
fail because a dependency is malformed.
The traditional behavior of rpm is to
succeed in building, as there is no
definition of well formedness wrto
dependency tokens.

Note You need to log in before you can comment on or make changes to this bug.