Bug 64327 - kernel doesn't honor O_SYNC on open
kernel doesn't honor O_SYNC on open
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
pensacola
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Larry Woodman
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-02 11:01 EDT by David Mansfield
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-02 13:17:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Mansfield 2002-05-02 11:01:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020308

Description of problem:
I have a test benchmark that I've been running on various systems.  When I run
it on pensacola, it scores about 1500% better, but it's because it isn't
honoring the O_SYNC on open.  I can verify this because: 

1) the score is the same with or without the flag
2) adding an fdatasync() call slows it down to the same level as
on other systems
3) I/O continues long after the process has terminated, and ps shows kupdated
doing the writing.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. open a file with O_SYNC and notice that it's not.
2.
3.
	

Actual Results:  asynchronous file writes

Expected Results:  synchronous file writes

Additional info:

Note You need to log in before you can comment on or make changes to this bug.