Bug 643296 - racy crashes across all applications
Summary: racy crashes across all applications
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 13
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-15 08:11 UTC by Jan Kratochvil
Modified: 2018-04-11 09:52 UTC (History)
6 users (show)

Fixed In Version: pulseaudio-0.9.21-6.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-21 22:01:24 UTC
Type: ---


Attachments (Terms of Use)
Fix. (489 bytes, patch)
2010-10-15 08:11 UTC, Jan Kratochvil
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
PulseAudio Bug Tracker 859 0 None None None Never

Description Jan Kratochvil 2010-10-15 08:11:33 UTC
Created attachment 453668 [details]
Fix.

Description of problem:
Crashes in multithreaded environment.

Version-Release number of selected component (if applicable):
pulseaudio-0.9.21-6.fc13.x86_64 
firefox-3.6.10-1.fc13.x86_64

How reproducible:
Always.

Steps to Reproduce:
http://js1k.com.nyud.net:8080/demo/730

Actual results:
It crashes in 1 to 5 seconds. 

Expected results:
No crashes.

Additional info:

Comment 1 Jan Kratochvil 2010-10-17 15:39:57 UTC
According to:
 * http://fedoraproject.org/wiki/Policy_for_nonresponsive_package_maintainers
 * Is PulseAudio dead?
   http://lists.fedoraproject.org/pipermail/devel/2010-August/140095.html
 * http://pulseaudio.org/ticket/859 filed on 2010-09-29 (2+ weeks now)
 * pending commit request since 2010-10-15 (two days ago)
   https://admin.fedoraproject.org/pkgdb/acls/name/pulseaudio
starting the nonresponsive package maintainer process - the Outline item 1.

Comment 2 Jan Kratochvil 2010-10-24 11:23:19 UTC
Requesting application of the fix, first retry attempt according to:
Policy for nonresponsive package maintainers

Comment 3 Jan Kratochvil 2010-11-01 10:52:16 UTC
Requesting application of the fix, second retry attempt according to:
Policy for nonresponsive package maintainers

Comment 4 Jan Kratochvil 2010-11-07 17:49:28 UTC
Policy for nonresponsive package maintainers
process has been completed after the 3 weeks.
Going to verify the status with Lennart Poettering and make a post
to fedora-devel.

Comment 5 Martin-Gomez Pablo 2010-11-20 13:49:11 UTC
I can't reproduce the bug with either Firefox 3.6, Chromium or Firefox4.

Versions used :
pulseaudio-0.9.21-6.fc13.x86_64
firefox-3.6.12-1.fc14.x86_64
firefox4-4.0-0.12.beta7.fc14.remi.x86_64
chromium-8.0.560.0-2.fc14.x86_64

Comment 6 Jan Kratochvil 2010-11-20 18:30:50 UTC
Reproducible also on:
pulseaudio-0.9.21-6.fc13.x86_64
firefox-3.6.12-1.fc13.x86_64

But I do not have F14 box with audio ready now.  It may be related to the number of CPU cores (reproducible on my i7-920=8x but even on my T7200=2x).

Comment 7 Jan Kratochvil 2010-11-20 18:55:51 UTC
And reproducible also on single-core AMD XP 2600+ (F13 i686).

Comment 8 Fedora Update System 2010-11-20 23:35:17 UTC
pulseaudio-0.9.21-7.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/pulseaudio-0.9.21-7.fc13

Comment 9 Fedora Update System 2010-11-20 23:47:41 UTC
pulseaudio-0.9.21-7.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/pulseaudio-0.9.21-7.fc14

Comment 10 Fedora Update System 2010-11-20 23:54:45 UTC
pulseaudio-0.9.21-6.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/pulseaudio-0.9.21-6.fc12

Comment 11 Fedora Update System 2010-11-21 22:01:19 UTC
pulseaudio-0.9.21-7.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Michal Schmidt 2010-11-22 15:22:28 UTC
Matěj,
did you make sure the patch gets applied upstream?
Also, we might as well just configure with "--disable-legacy-runtime-dir", because the last pulseaudio version using the legacy path was 0.9.11 which was in the Fedora 9 timeframe.

Comment 13 Matěj Cepl 2010-11-24 19:41:34 UTC
(In reply to comment #12)
> did you make sure the patch gets applied upstream?

I have been assured by the maintainer that he is going to make upstream release incorporating what's appropriate from Fedora patches.

> Also, we might as well just configure with "--disable-legacy-runtime-dir",
> because the last pulseaudio version using the legacy path was 0.9.11 which was
> in the Fedora 9 timeframe.

I don't know, I will rather leave it to the upstream maintainer to decide. I was here just fixing this stupid bug.

Comment 14 Fedora Update System 2010-11-24 22:40:44 UTC
pulseaudio-0.9.21-7.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2010-11-29 21:28:35 UTC
pulseaudio-0.9.21-6.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.