Bug 643300 - [abrt] epiphany-1:2.30.6-1.fc14: glyphDataForCharacter: Process /usr/bin/epiphany was killed by signal 11 (SIGSEGV)
Summary: [abrt] epiphany-1:2.30.6-1.fc14: glyphDataForCharacter: Process /usr/bin/epip...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: webkitgtk
Version: 14
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Gordon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3094d14c126c6fd039006adef09...
: 647249 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-15 08:29 UTC by Martin Sourada
Modified: 2010-11-22 22:17 UTC (History)
10 users (show)

Fixed In Version: webkitgtk-1.3.6-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-22 22:17:14 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (30.46 KB, text/plain)
2010-10-15 08:29 UTC, Martin Sourada
no flags Details


Links
System ID Priority Status Summary Last Updated
WebKit Project 14550 None None None Never

Description Martin Sourada 2010-10-15 08:29:08 UTC
abrt version: 1.1.13
architecture: i686
Attached file: backtrace
cmdline: epiphany
comment: Sometimes it crashes even before finishing loading, sometimes even sooner. Reproducible in both epiphany and midori so I suspect webkitgtk.
component: epiphany
crash_function: glyphDataForCharacter
executable: /usr/bin/epiphany
kernel: 2.6.35.6-39.fc14.i686.PAE
package: epiphany-1:2.30.6-1.fc14
rating: 4
reason: Process /usr/bin/epiphany was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1287125408
uid: 500

How to reproduce
-----
1. visit http://stg.fedoraproject.org/

Comment 1 Martin Sourada 2010-10-15 08:29:12 UTC
Created attachment 453671 [details]
File: backtrace

Comment 2 Martin Sourada 2010-10-16 09:56:06 UTC
Reassigning to correct component.

WebKitGTK+ version: webkitgtk-1.3.4-3.fc14.1.i686

QTWebKit and KHTML do not suffer from this issue.

Comment 3 Kevin Fenzi 2010-10-16 20:10:33 UTC
Yeah, this looks like a webkitgtk issue with the custom font used on that page. ;( 

Interestingly chromium does not have this crash here, so they must have some fix in their local bundled webkitgtk. ;( 

I can try and come up with a min test case to file an upstream bug... but if someone else could that would be great. ;)

Comment 4 Kevin Fenzi 2010-10-16 20:23:23 UTC
Some poking around gave me: 

https://bugs.webkit.org/show_bug.cgi?id=46878
and
http://code.google.com/p/chromium/issues/detail?id=56035
and
http://code.google.com/p/chromium/issues/detail?id=55215

But sadly, I don't have permissions to view any of those, so I can't be sure it's the same bug or what the status of fixing it is. ;( If anyone can view them and see that would also be great. 

ie, see: 
http://groups.google.com/a/chromium.org/group/chromium-bugs/browse_thread/thread/89e598f8094949a7?fwc=1

Comment 5 Jaroslav Reznik 2010-10-20 19:43:30 UTC
(In reply to comment #4)
> Some poking around gave me: 
> 
> https://bugs.webkit.org/show_bug.cgi?id=46878
> and
> http://code.google.com/p/chromium/issues/detail?id=56035
> and
> http://code.google.com/p/chromium/issues/detail?id=55215
> 
> But sadly, I don't have permissions to view any of those, so I can't be sure
> it's the same bug or what the status of fixing it is. ;( If anyone can view
> them and see that would also be great. 
> 
> ie, see: 
> http://groups.google.com/a/chromium.org/group/chromium-bugs/browse_thread/thread/89e598f8094949a7?fwc=1

Looks like this is original report - https://bugs.webkit.org/show_bug.cgi?id=14550. 46878 was closed as duplicate of 45620 and it was closed as duplicate of 14550.

Comment 6 Rex Dieter 2010-10-20 20:16:28 UTC
14550

Comment 7 Kevin Fenzi 2010-10-20 20:41:40 UTC
Unfortunately, I can't get that upstream patch to apply cleanly to 1.3.4. ;( 

Also, I'm heading off on a trip... so if anyone else is able to get it building so we could test it that would be great.

Comment 8 Kevin Fenzi 2010-10-27 17:52:56 UTC
Odd. I can't get the upstream patches to apply vs 1.2.5 or 1.3.4/1.3.5. I guess they are against a trunk version or some other stream?

If anyone else has time to poke at them, it would be good to backport this to our versions since this affects fedoraproject.org which is the default page on many of our browsers. ;)

Comment 9 Kevin Fenzi 2010-10-30 21:36:01 UTC
Can folks seeing this please try: 

http://koji.fedoraproject.org/koji/buildinfo?buildID=202495

Works here in midori. I'll probibly push this as an update in a bit, but more feedback would be great.

Comment 10 Martin Sourada 2010-10-31 07:26:11 UTC
Thanks for the update! It works for me (tried epiphany and midori) :-)

Comment 11 Fedora Update System 2010-10-31 16:22:46 UTC
webkitgtk-1.3.5-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/webkitgtk-1.3.5-1.fc14

Comment 12 Bruce Cowan 2010-10-31 19:42:22 UTC
*** Bug 647249 has been marked as a duplicate of this bug. ***

Comment 13 Fedora Update System 2010-10-31 21:32:47 UTC
webkitgtk-1.3.5-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update webkitgtk'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/webkitgtk-1.3.5-1.fc14

Comment 14 Fedora Update System 2010-11-09 18:54:17 UTC
webkitgtk-1.3.6-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/webkitgtk-1.3.6-1.fc14

Comment 15 Fedora Update System 2010-11-22 22:17:08 UTC
webkitgtk-1.3.6-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.