This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 643310 - Guest failed to get ip after hot add NIC card
Guest failed to get ip after hot add NIC card
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
All Linux
low Severity medium
: rc
: ---
Assigned To: Michael S. Tsirkin
Virtualization Bugs
: Triaged
Depends On:
Blocks: Rhel5KvmTier3
  Show dependency treegraph
 
Reported: 2010-10-15 05:05 EDT by juzhang
Modified: 2011-07-04 00:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-16 14:10:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description juzhang 2010-10-15 05:05:08 EDT
Description of problem:
Boot guest,then hot added nic using the following command:
(qemu)pci_add pci_addr=auto nic vlan=2,macaddr=00:1a:4e:9f:0b:60,model=virtio
(qemu)host_net_add tap script=/etc/qemu-ifup,vlan=2
however,guests can't get ip.


Version-Release number of selected component (if applicable):
#rpm -qa | grep kvm
kvm-qemu-img-83-204.el5
kvm-debuginfo-83-204.el5
etherboot-roms-kvm-5.4.4-13.el5
kvm-tools-83-204.el5
kmod-kvm-83-204.el5
etherboot-zroms-kvm-5.4.4-13.el5
kvm-83-204.el5


How reproducible:
100%

Steps to Reproduce:
1.boot guest
#/usr/libexec/qemu-kvm -rtc-td-hack -no-hpet -usbdevice tablet -drive file=/var/lib/libvirt/images/demo.raw,if=virtio,format=raw,werror=stop,boot=on -net nic,macaddr=10:10:20:34:23:12,model=virtio,vlan=0 -net tap,script=/etc/qemu-ifup,vlan=0 -uuid `uuidgen` -vnc :20 -cpu qemu64,+sse2 -smp 2 -m 2G -monitor stdio -drive file=/dev/cdrom,if=ide,media=cdrom -balloon virtio
2.hot add nic
2.1 (qemu) pci_add pci_addr=auto nic vlan=2,macaddr=00:1a:4e:9f:0b:60,model=virtio
OK domain 0, bus 0, slot 7, function 0
2.2 (qemu) host_net_add tap script=/etc/qemu-ifup,vlan=2
3.check network
(qemu)info network 
VLAN 0 devices:
  tap.0: ifname=tap1,script=/etc/qemu-ifup,downscript=/etc/qemu-ifdown
  virtio.0: model=virtio,macaddr=10:10:20:34:23:12
VLAN 2 devices:
  virtio.2: model=virtio,macaddr=00:1a:4e:9f:0b:60
  tap.2: ifname=tap4,script=/etc/qemu-ifup,downscript=/etc/qemu-ifdown

Actual results:
Guest find new nic,however,failed to get ip

Expected results:
Guest can get ip.

Additional info:
1. Using the same steps,when hot added nic,if  first issue command (qemu)host_net_add tap script=/etc/qemu-ifup,vlan=2,then issue command (qemu)pci_add pci_addr=auto nic vlan=2,macaddr=00:1a:4e:9f:0b:60,model=virtio.
Guest can get ip.

 (qemu) host_net_add tap script=/etc/qemu-ifup,vlan=2
 (qemu) pci_add pci_addr=auto nic vlan=2,macaddr=00:1a:4e:9f:0b:60,model=virtio
OK domain 0, bus 0, slot 7, function 0

2. I  tested rhel6 and windows2008 r2,both hit this problem.
Comment 4 RHEL Product and Program Management 2011-01-11 15:16:48 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2011-01-11 17:53:42 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Note You need to log in before you can comment on or make changes to this bug.